Issues of sampler track

Hi there,
first of all I wish you good luck for the new year and never ending inspiration.

Here are my actual issues with the new sampler track

  1. If I double click on a sampler track it opens in the lower zone, but I want it opened by a separate window, like all other editors. I disabled the lower zone except the transport bar. Sampler track (ST) brings back the whole stuff and I have always to shut it off when I want to edit the ST. Both parameters in Settings->Editors are set to show in separate windows. Annoying. I don’t like THAT!

  2. ST seems to have issues with FLAC files. Either creating a sampler track from Media Bay or from an existing audio event in an audiotrack leads to a crash instantly if it is a FLAC file. Seems an error. Please try that. If it’s not only me I would write an issue report. Thanks.

  3. STs don’t show up in Cubase iC Pro. Is this normal.

Salve

Sorry to hijack your thread.



I just noticed that the sampler doesn’t import the audio in to the project audio folder. Anyone know how to get it to import to audio folder by default?


Michael

Why should it? My understanding is: STs don’t alter your audio file except you edit it in Audio Editor. It leaves the audio files where they are.

All the audio should be inside the project audio folder so you can back up, or wetransfer to another producer etc.

Then you should open a feature request or copy your audio files to a project related folder before importing to ST.




Thats not a great option is it?


I’m just asking if anyone has seen an option in prefs for this. It’s not a big deal.

Ok, I understand. But what would you do if you use another sampler like Kontakt or Halion?
I didn’t tried it yet. Possibly the sample is already stored in the project. We should try that.
If not your suggestion to make it optional would be convenient.
If not we should save the affected files before importing. It"s just a workaround which surely helps.
It is an option at least.

It makes sense to me that when importing sample the ST (SampleTrack) makes its own copy of the wave so you can manipulate it and not affect the original wav. Actually I thought I noticed some folder created in my /audio folder… but I didn’t know why.

If you drag an audio file into an audio track it does not automatically import the file into the pool. I use the Archive function to do this. Does this work for the sampler? I am not at my machine and have not used the sampler yet.

When you drag an audio file in to cubase It opens up a dialogue box called import options - if it doesn’t for you then you turned off the box in prefs. (there’s a check box saying please don’t ask me again in the dialog box). It would be crazy frustrating opening up old projects that were referencing old hard drives, sample locations etc otherwise.

Yeah you’re right Groove Agent doesn’t import the sample to the audio folder - I see why its doing it, so you can stream larger kits etc off an external drive and it doesn’t give you read/write issues. For the sample track thats not an issue however. I’ll bring up a feature request.

The issue regarding flac files is accepted in the bug forum

https://www.steinberg.net/forums/viewtopic.php?f=254&t=110474

Thanks for reminding me. This was a hangover from 8.5 as drag and drop was broken for me, despite having the right boxes ticked. I had to import every file which got very annoying.

The other one bringing the lower zone is approved too.
https://www.steinberg.net/forums/viewtopic.php?f=254&t=110523&e=0