Issues on working with frames

I’m trying to work on frames and frame chains on my score. For some reason, things don’t happen as in the tutorials.
In the tutorials, when one drags a frame smaller, the rest of the music in the frame flows on subsequent pages. When I do it on my score, it just often shrinks the frame in a tight little mess.
Also, if I set the note spacing smaller in the settings, at some point of the score it puts two frames on top of each other, a mess again.
Do I have some setting on that causes this?
A related question: how can I prevent the music in a flow from going over to the next flow? This also happens, when I try to work on the frames.

Welcome to the forum @Jaani_H !

Music frames will show all the staves in a system. It’s possible that the video tutorials you’ve seen have involved part layouts where each system only contains one staff (e.g. just the violin in the Violin part), meaning when the music frame got shorter, fewer systems could fit so the bottom systems got pushed into the next frame. Dorico will automatically create new pages if needed to display all the music that the Default page template’s music frame chain is set to show (by default, those are the music frames that show MA in their top left corner.)

In your screenshot, it looks like there are several staves in each system as it’s an ensemble piece? So unless you use the frame selectors to filter specific instruments you want to show in the frame (which are only accessible on individual pages for layout music frames, as page template frames can only be edited in terms of which staves/flows they show on the corresponding page template), then Dorico will try to show all the set music in whatever space the frame takes up. E.g. as in this video:

On the left page in your screenshot, music is overlapping because you have two overlapping music frames. If you don’t want them to appear on top of each other, make sure the bottom edge of the upper frame is above or in line with the top edge of the lower frame.

When you say you changed the note spacing, and that resulted in frames overlapping – do you instead mean you changed the page size? Depending on how frame constraints are set, the size, shape, and position of frames can be different when you change the page size.

Dear Lillie,

thanks for the swift reply! It cleared the thing with shortening frames. My piece is an ensemble piece and has five staves in one system. I see now the point, that shortening the frame cannot break the staves.

I did indeed change only the note spacing smaller and it caused two frames overlapping. But if this happens, then you just need to drag the frames in their right respective places, I guess?

Two things I haven’t really figured out yet. I’d like to make the general font (all the music, staves, all musical material in my score) smaller, because I’d like to accommodate three systems on a page instead of one or two, that Dorico does automatically. How do I accomplish this?

Then, I wonder what is the best way to move frames from one page to the other. Is it just the copying function in the pages section, and then you need to drag the frames in the right positions?

Thank you!

Best wishes,

ti 15. maalisk. 2022 klo 13.23 Lillie Harris via Steinberg Forums <> kirjoitti:

Layout Options > Page Setup > Space Size

It would be better to tell us what you’re trying to accomplish. If you’re having to move frames all the time, most likely you’re using Dorico wrong.

You shouldn’t need to be dragging staves around at all. Adjust the Layout Options (staff size, vertical spacing, music margins, etc.) to get the results automatically. Only in rare instances will you need to adjust staves manually (and that should only be very slight adjustments). Remove any manual system or frame breaks to allow the music to reflow as needed – only use them if actually needed. (turn on View Signposts if you can’t see them). If you DO use a Frame Break, look in the Properties panel for the “Wait until next Frame Break” parameter [Engrave mode], and uncheck if it is ticked. Otherwise, all music will be squished into that single frame.

Thank you so much, this was most helpful!! It was crucial to switch the page size to A3, hadn’t at all realised before what it really meant. The other crucial thing was to remove all overrides on the pages section. I had been trying out different engraving options before and that had messed up the score. I’m so relieved I’m getting the hang of it now, thanks!!!

ti 15. maalisk. 2022 klo 22.46 Dennis Larson (OSLC) via Steinberg Forums ( kirjoitti:

If you’ve been dragging staves up or down, go into Engrave mode with the Staff Spacing tool selected. For any staff boxes that are red, click on the box, then Delete. This will restore full automatic vertical spacing without manual overrides. Once you start changing things here, Dorico can’t do what it is supposed to. Any spacing changes here should be very minimal (if at all). Instead, tweak the Layout Settings to obtain your desired results. It will save a vast amount of time by not needed to manually reposition everything. (Sibelius was too easy to just manually tweaked staves – Dorico seeks to avoid manual intervention unless absolutely necessary… but it should be rarely needed.)

If you haven’t yet watched this excellent video by John Barron, it will help you with the many layout adjustments that are possible.