Issues when triggering macro through MIDI


I’m currently building a custom control surface for a huge films-scoring template with over 1700 tracks.
The controller is an iPad running Midi Designer software, and it is set up to trigger through a Generic Remote in Cubase.
I can get pre-defined and small macros to run without any noticeable issues, but I am currently trying out a big “show/hide tracks”-macro which is made up of 13 Logical Editor scripts in a particular sequence.

I’ve attached a couple of images which shows the setup. As you can see from the images, I’ve set up the macro to be triggered by a key-command also (Command+Control+Option+T) and this works without any issues. But when I try to trigger the same macro through the Generic Remote, either nothing happens, or it just finishes some of the macro-steps and, seemingly, ignoring the others. I’ve tried with a midi keyboard also - same result. Midi from all devices looks normal in a midi monitor, so it seems to me like a normal qwerty-keyboard has privileges that the midi controller doesn’t have.

I read somewhere in an old forum-post that Cubase can only handle 2-3 Logical Editor scripts in a macro (even though this wasn’t documented anywhere), but since the macro works without issues through a normal qwerty-keyboard trigger, I don’t see how this could be the problem.

I’m on a Mac (OSX 10.10.3) and running the latest version of Cubase 8 Pro.

All tips and ideas are highly appreciated!

I tried running them on a PC running Cubase 7.5 with the same result.
I also found out that I over-complicated things and got the number of Logical Editor scripts down to three (at least for what I’m doing now), but this made no difference either.


Yes you’re right. Macros don’t execute right at all. It’s a mess. Even with my iPad I have to keep using Keyboard maestro. Please file a bug report.

I’ve reported this to Steinberg who experienced the same behaviour. Their dev-team has been noticed and it will/may be fixed “sometime in a future update”, so who knows… It’s annoying as hell!

A possible work around until it’s fixed might be to use something like Bome MIDI Translator to trigger the macro?

Thanks, Brian, that looks to be a nice work-around for now! Hopefully I won’t run out of available key-kommands :wink:

I use Keyboard Maestro for macros. Works great

Yes I got the same from Yamaha:

I am seeing some inconsistent behavior myself. I am going to do some further testing as well as contact development. I just wanted to keep you up to date on where i was at with your case.

If you have any questions, please let me know.

Thank you
Jeff Deno
Steinberg US Support

Thanks for the update!

I haven’t tried Keyboard Maestro before, but I’ve used QuicKeys on a couple of ocations. It might be just my lack of programming-skills, and I’m aware that you can do highly sophisticated macros with such software, but doesn’t it all rely on certain windows being a certain positions on-screen for it to work…?