ISSUES with eLicenser (CUBASE) what the heck is this

Hello Steinberg community,

I wanted to start cubase AI for the first time and was asked to enter the access code. After I entered the code the option “activate license” was unlocked. As soon as I clicked on it I was informed that the eLicenser is too old. Although I sychronized, downloaded and installed the software a few times nothing changed.

Somehow the elicenser didnt have any issues accepting the Basic FX Suite but the AI software it won’t validate. Very disappoiting.

What can i do?
(Running the elicenser as adminstrator did not impact the result)

When I use mysteinberg, in order to check on my request, I get automatically logged out with the message “goodbye”. Whether this a case of incompetence or audacity I don’t know. In any case it is maddening. The interface I bought was advertised with cubase AI included and therefore this is simply unacceptable. I tried to check on my request many times on three different device with the same result.

Ive just downloaded, installed and started another DAW. This didn’t take me a minute and was completly free. What a bliss! A full Version that works even after the 60 day trial limitation only asking for registration. Unfortunatly I could not get to enjoy cubase, because of the DRM. Maybe this and the lack of traffic on the steinberg forum will motivate one or the other cubase user to make the switch to another DAW. I will keep you updated, how well the steinberg customer service will perform. I have received a confirmation Email of my request on wednesday. As of now (friday) no answer.

Hi,

I’m sure were not asked for an Access Code.

The process is following:

  • in your MySteinberg account use the Download Access Code to get an Activation Code.
  • In the eLCC application enter the Activation Code to download the license.
  • In the eLCC application register your Soft-eLicenser and the license.
  • Start Cubase and click to “Already Registered”.
    Done.

Make sure you have the latest elicenser installed:-
https://www.steinberg.net/en/company/technologies/elicenser.html

Thanks guys, I went for another attempt and now I am able to start cubaseb ai 10. However when I use the menu bar once it ignores every input from then on until j restart the program. What am I doing wrong?


A tip ive recieved:
Graphics driver update or deactivating HiDPi.

I will install a new graphics card on monday, hopefully that will resolve it