Issues with exporting individual WAVs in D4


For some reason when I try to export audio of individual parts and specific part arrangements, the audio doesn’t portray what I ask for? Is this a bug in D4?

Thanks in advance,
Ian Hook

In Setup Mode on the right side is a column with all available layouts. During export Dorico always uses the topmost layout from that list. By dragging and dropping you can change the list order. Does that help you?

In fact, as of Dorico 4, it no longer uses the topmost layout in the Layouts panel, but rather it uses the current layout that is active in the frontmost window.

But you don’t provide much information, Ian, about what you expect to happen versus what is actually happening. Please provide some more specific information about the nature of the problem you are experiencing and we should be able to assist.

1 Like

@dspreadbury & @Ulf , The layout I’ve been trying to export is not the topmost layout so maybe that’s the issue. The layout I’ve been trying to export is the current layout.

It’s a vocal barbershop-like score with 4 pianos, 2 electric guitars, 1 bass guitar, 1 trumpet and 1 drumset. When I am on the drumset player layout I’m getting voices and my guide piano (not previously mentioned). I tried soloing DS in the mixer but that didn’t work either, I just got a silent audio file. I tried the option in the export menu that says “export individual parts” and selected only drumset; Unfortunately, that file didn’t have any sound either.

I created this in Dorico 3.5, that shouldn’t be an issue right?

My top layout is the barbershop and guide piano layout.

Perhaps you could attach the project itself here, Ian, so we can try it for ourselves.

Here it is @dspreadbury

I Get Around.dorico (3.3 MB)

(First Flow, Second was just a .mxl import)

Hi @Ian_Hook05 , I’ve just had a quick look and did not export anything, but opening your project and going to Play mode, I noticed that the trumpet is on solo and everything else is therefore muted.
If you correct that solo state, does it then export properly for you?

The Trumpet was on Solo so I could export the Trumpet part but it didnt work, I still just got voices.

When I deactivate all Mute/Solo states and export, I can hear the voices plus the trumpet.

Can you export individual voices as well?

I’ll check tomorrow morning

Yes, I do. As I said, I open your project, go to Play Mode, clear all solo/mute states and then open the export dialog. On the right I tick ‘Export players as separate files’ and after export there is sound in the individual wave files for players selected in the Barbershop Only layout. Everything quite as expected.