Issues with "Hide all identical tuplets"

If I choose to hide all identical tuplets, the number of repeated tuplets is not satisified if a rest is enountered, or if the next tuplet is rhythmically contiguous but still on the same grand staff. In the example, I chose number of tuplets N= 2. As you can see from the first page, the 2 tuplets condition was satisfied in the first measure of the treble clef of the harp part, but not in the bass clef, which had no two contiguous tuplets:
It is finally (luckily) satisfied on the second page in measure 8:
It’s pretty messy looking. For this simple harp part I can use a repeat N=1, but I can think of some more complex cases where it would be important to be able to choose either which staff to monitor, or to have Dorico look for rhythmically contiguous tuplets on both staves. Or maybe I’m missing something.



Did you try setting ‘Hiding repeated tuplets’ to ‘Hide all identical tuplets’ at the bottom of the Tuplets page of Engraving Options? That should allow Dorico to look beyond the rests in each staff and keep hiding the tuplets for you.