Issues with playback and crashes

Hello! Posting here for the first time in hopes of getting some guidance for a problem my Google skills have been unable to solve.

I use NotePerformer and a USB MIDI device for playback on my up-to-date Windows 10 PC. Today, I opened a project I had been working on yesterday, but could not get playback to work – the options to select the playback device were greyed out, and trying to make any changes to the VST instrument I was using, like deleting or selecting something else instead of NotePerformer, resulted in crashes. I haven’t been able to get any kind of playback from Dorico at all. The problem now occurs with every project I try to open, and new projects as well – I’ve even tried reinstalling Dorico and NotePerformer but no luck. Any advice on what I could try or any more details that would help? Any tips would be appreciated!

Welcome to the forum, @ajglass18. Can you please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a look? Hopefully there will be some crash dumps included that should allow us to see what’s going on.

Hi Daniel, thank you for the quick reply! Is there a way besides links and direct attachments to send the .zip file? At almost 10MB it’s too large to upload directly.

Hi @ajglass18 , please send directly to u dot stoermer at steinberg dot de. Thanks

Just sent, thank you!

Thanks very much, found it in my junk mail, but it is there.
So your diagnostics contain plenty of crash dumps of the audio engine. I currently don’t have my developer tools at hand, so can’t take a closer look, but I will do so in around 10 hours from now, so a little patience please. Thanks

I really appreciate that, thank you!

Hi @ajglass18, looking at the crash dumps, it turns out that they are not actual crashes, but the audio engine’s main thread is blocked by your MOTU driver, because that one is indefinitely waiting for a system resource or something. Though it is not a crash, but the effect is the same, nothing is moving and the audio engine is stuck. As to why or what for the MOTU driver is waiting, I can’t tell, only the people from MOTU can do.
But in the log files I’ve also noted one thing and that is, your MOTU is set to a sample rate of 192 kHz. First of all, that high sample rate is officially not supported by Dorico, second, why do you set it to such a high rate? Sample rates higher than 48 kHz make no sense in Dorico, because you don’t record audio in there and sample libraries usually come only in 44.1 or 48 kHz, so playing back these libraries in 96 or 192 kHz does not bring any advantage and only puts higher strain on your machine.
So please try and set your MOTU to 44.1 or 48 kHz and see how Dorico then behaves.

Thanks for looking into this, Ulf! Changing the sample rate of the MOTU (I was using it to track instruments in Cubase) to either 44.1 or 48kHz unfortunately didn’t fix the problem, but changing to a different ASIO device did, so I can at least get some kind of playback functional. The MOTU had worked fine even at the higher sample rates in the past but I’d recently reinstalled the drivers so will try some more troubleshooting on my end to see if I can narrow down that problem – thanks for your help!

For posterity in case anyone else runs into a similar issue, completely uninstalling the MOTU M4 drivers and reinstalling the latest ASIO drivers seemed to fix the problem – full playback with NotePerformer via my interface is working again. Glad it’s so easy to get help from the Dorico team!