Issues with Steinberg Activation Manager

Hi, so last November I upgraded to Cubase 12. I registered it with my eLicenser (I didn’t know about SAM at that point). Turns out, I need to register Cubase 12 with SAM as well. I installed it at first on my Windows 10 machine and at first it worked fine. Then, for some reason I had to reinstall it, and that’s where problems started. I was not able to log into the SAM anymore.
These are the issues I’m having:
I can start it only once. It gets through the loading screen (it takes a few mins though). Then when I need to log in, I get an error saying that I’m offline, but I’m not offline. Although I get this message, the page opens in the browser where I logged into my account, so next I have to click a button, so it would log me into the SAM. It never happens. If I shut down SAM, I cannot open it again. I have to restart my computer, and then it opens up.

I read a lot of posts on this forum and tried almost everything:

  • I turned off my antivirus and firewall
  • Cleaned my registry
  • Reinstalled SAM
  • Reinstalled all of the Steinberg products
  • Tried different browsers (Edge, Brave, Chrome, and Firefox)
  • Turned VPN on and off
  • Deleted \APPDATA%\Steinberg\Activation Manager\ folder
  • Ran antivirus to check if I have any viruses.
  • Took off eLicenser
    Nothing helped.

The only thing that kinda worked was installing SAM on my laptop and activating it as it is on offline computer. Although, I can get Cubase work this way, Amped Elektra doesn’t work as well as many other (free) plugins and add-ons for some reason (I’m also using my eLicenser USB thing-y). I just get an error every time I launch Cubase that these products are not activated. And I can’t activate them because SAM doesn’t want to do it automatically + I have no idea how to activate them offline.

And I don’t really want to activate them via my other computer as my main one (where my Cubase is at) has an internet access.

Any ideas on how I can fix this problem? Thank you!