Issues with the Apple pencil in D5 for IPad

The apple pencil doesn’t work properly anymore with D5 for IPad. All actions in the menu like filtering, transpose, transform etc. for selected notes don’t respond, if you use the pencil . Just nothing happens, if you tap on these items with the pencil. In the portrait view the playback buttons don’t respond to pen touches .

I’m having similar issues - many of the interface elements aren’t working with pencil touches.

I’m confused. Has Dorico for iPad been updated? Are we supposed to be able to input and move notes with the pencil?


Dorico for iPad has been updated, but there is no additional support for Apple Pencil in this release. However, tapping interface elements with the Pencil should work the same in Dorico for iPad 5.0 as in earlier versions. @wibem1, are you finding that you can’t tap on menu items in the score context menu (on the secondary toolbar) with the Pencil?

The pencil taps work with the general menu (3 lines), but not with the inner special menu (3 dots).

I’m having many more problems with this new Dorico update for the iPad; regardless of the Apple Pencil, double tapping in the score to start the carrot at that moment does not work, with the fingers or with the pencil. A lot of functionality with the pencil in note input, also selecting note duration is not working, clearly bugged, because in the previous version this worked seamlessly. Any way to update this quickly or perhaps downgrade to the previous version? This makes the app almost unusable, and I’ve been using it every day.

1 Like

Dorico is not responding when typing in the score to get the carret . Note duration is not working either, one have to use fingers, the(3_lines ) at the top right are not visible. I tried to reinstall D5 4 times but nothing happen.

Welcome to the forum, @am1. Please try rotating your device to the other orientation and then back again, and you should see the application menu appear.

Double-tapping to start note input is indeed not working since we moved to the newest version of the Qt framework, and while it’s inconvenient, you can still start note input by tapping on the dedicated button for that in the toolbox on the left.

I do find that various buttons in the user interface reject the Pencil that didn’t used to – as of right now I don’t know what the reason for that is, but we will investigate.


Rotating the ipad to get the 3-line menu back in portrait does work but the icon is still cut at the corner (ipad pro 12.9). I. think before the update the corner were ok.

Bildschirmfoto 2023-05-26 um 00.21.17

In the menu, there are also some weirt artifacts if you change a setting or double tap a menuname.

blue artifacts in the middle:
Bildschirmfoto 2023-05-26 um 00.15.21

Box around the text:
Bildschirmfoto 2023-05-26 um 00.15.57

Glad to hear other people are experiencing this as well. I thought my Apple Pencil was on the fritz.

Working in D5 with the Apple pencil now is generally a pain. Beside the issue that some menu functions no longer respond to pencil taps, it’s quite hard to handle that the pencil now directly can move notes around. If you move the score with the pencil , you might as well move some notes and destroy the score. And sometimes you even don’t notice it. Why has the Dorico team changed the behavior of the moving- notes -function? And there seems to be no option to get back to the old behavior.

We haven’t deliberately changed it – this has changed as the result of the move to the newer version of the Qt framework that we use for all versions of Dorico across macOS, Windows and iPadOS. We’re looking into these issues and hope to have a fix soon.


I’m seeing a similar problem. Not one of the controls is active and selectable by any means on my iPad Pro 12.9" (M1) with the current version of iOS (16.5). That means I could not assign a name, key signature, time signature, number of bars, or anything but the template when creating a new project. I also could not change the player name.

I didn’t test any further than that because these problems made it impossible for me to use it at all. (I had to go to my notebook and do manual note entry with the full Dorico instead of using the iPad with my keyboard.)

I hope the fix does not take long!

You’re unable to use any of these controls even with your finger, @EWTHeckman?

That’s correct. I even tried it again just before leaving the message. Force quitting Dorico did not resolve the issue.

Thanks – we are looking into these issues right now, and we think we will be able to get some decent repairs done for the most egregious problems quite quickly.


Would it please be possible to somehow reintroduce this feature, to double tap to start the carrot? Or maybe move the note input button to anywhere but the most far corner, away from all the other controls you need? Like maybe put it (also) in the piano/note duration interface?

Like, literally the placement couldn’t be farther away from the natural position of your right hand when you’re holding the iPad (bottom right is most at hand right?). Here’s another free idea: place it in this movable note edit thingy where you can change pitch and duration and position!

1 Like

I just downloaded and did a quick test of the latest update. It looks like this particular bug has been fixed.