I've bought Noteperformer but Dorico can only open the trial version

when I want to open Dorico I get a:

C:\Program Files\Common Files\VST2\NotePerformer64.dll
A timeout may have occurred. Check if the plug-in is displaying a message or click ‘Cancel’ to put the plug-in on the blacklist.”

When I press cancel and open a project I get the “Welcome to the trial version of Noteperformer” even though I bought it…


Did you install the version you bought? It’s not the same as the trial version. Should have your name in the filename of the installer.


Yes I did.

and did you uninstall the trial version?

Yes, I also reinstalled everything Dorico and now the trial version is completely removed but the scanning and blacklist problem persists.

And Noteperformer does function on my old Sibelius :sweat_smile:

Please do Help > Create Diagnostics Report in Dorico and post the corresponding zip file here. Thanks

well if NotePerformer is on the vst2 whitelist and not on the blacklist then I start to get puzzled. Ulf will probably have some ideas – in general NP does work these days after a number of issues under Dorico 3 in days gone by!

UPDATE I see Ulf has already jumped in and I’m sure will get to the bottom of it.

h ttps://we.tl/t-rQpvazJKMd
The file is too big so I put a spacebar between the “h” and “t”

NotePerformer is indeed on the blacklist. Try trashing the folder

%APPDATA%\Steinberg\Dorico 4 AudioEngine_64

(Copy and paste that line into the address bar of File Explorer and hit the enter key. Then delete everything in there)
and restart Dorico.

C:\Program Files\Common Files\VST2\NotePerformer64.dll
A timeout may have occurred. Check if the plug-in is displaying a message or click ‘Cancel’ to put the plug-in on the blacklist.”
happens again.

Hm, you say that you have also a trial version installed. Maybe that is the problem.
Also on the blacklist NotePerformer appears twice, once in C:\Program Files\Common Files\VST2 and in C:\Program Files\Vstplugins\VST2
I’d try getting rid of one of them, trash the audio engine folder again and restart Dorico to trigger a new scanning.

(Btw, I’m away for dinner now, come back later…)

to be honest in your position, I’d check all the vst2 locations listed in Dorico’s VST preferences and delete all the NotePerformer.dll’s you find, then reinstall NotePerformer one more time. That should give a clean installation to finally check your white and blacklist against. Sibelius may be reading from a different location for the plug-in which could explain why it’s working and Dorico isn’t. These issues cannot occur with vst3 plug-ins as they have a fixed installation location but NP isn’t there yet.

If it’s still not working, the ever-industrious Ulf will return from his dinner at some point. :grinning:

1 Like

Still no good news, I removed all the NotePerformer.dll’s I could find, deleted Dorico and NotePerformer and reinstalled it all again with the same result.
h ttps://we.tl/t-tAmMEJZ6qC (the diagnostics report of this trial)

It is still blacklisted.

Then, please do the following: Press the Windows key and then type cmd and press enter.
In the upcoming Command Prompt window copy and paste "C:\Program Files\Steinberg\Dorico4\VSTAudioEngine\Components\vst2xscanner.exe" -p "C:\Program Files\Common Files\VST2\NotePerformer64.dll"
Copy everything in bold, also the quotation marks. When you then press enter, what does it spit out?

I finally fixed it! I had to downgrade my AMD (adrenalin edition) driver (version 22.11.1) back to 22.5.1 so I can’t update my drivers for now it seems but I think this works for me. Thanks for helping!

Oh, good to hear that you’ve fixed it.
I was just about to ask if you have an AMD graphics card.
That with the driver is a known issue, though the symptoms on your system were a little different to the cases before. But anyhow, you have it going again.
It is also worth notifying AMD about your problem so that they fix it in their driver.