iZotope RX2 & WL key commands

When using iZotope RX2 plugins it is impossible to use WL key shortcuts like F6/F7/F8.
If I only click the opened plugin window (for example when only moving it around) it works however once I change the settings / move sliders withing the window itself, WL somehow loses focus and the key commands are not working anymore - to make them work again I have to click outside the plugin window.

If the plugin is the active window, it has the priority over WaveLab to trap key commands. Maybe it is possible to disable key commands in the plugin?

In short: in WL 6 it works.

More descriptive: doing the very same procedures with the very same plugins in WL 6 I still can use F6/F7/F8 key commands whenever & whatever I do.
And as I wrote making the window active in WL 7 is fine (e.g. key commands still work) - it is only once I click inside the window that WL 7 loses focus.

This bug is NOT fixed in version 7.1 :angry:
PG, you simply ignored me on this one :confused: Because of this issue I (still) cannot switch to WL7 and I have to keep using WL6 only.
I repeat, in WL6 this bug is not present and global WL keys work fine all the time. I just checked Cubase 6.0.1 and there everything is fine too e.g. it must be something wrong within WL7 code.
PLEASE, fix this ASAP! Otherwise I don’t see the point of reporting issues here…

Maybe Izotope does some special key processing when WaveLab 6 or Cubase is the host, because in WaveLab 7, when this problem occurs, WaveLab does not “see” any key pressed. The key is “eaten” by the Izotope plugin, and not passed through to WaveLab. In other words, there is nothing I can do. You should tell Izotope.

?? I am confused - it is the host that differs (WL6 & C6 vs. WL7) and not the iZotope plugin which stays the same hence I would assume it must be something within the host’s code. And you are the author of both WL6 and WL7 so you should know what are the differences - the fact is that WL7 apparently behaves differently to WL6… But I am not a programmer myself, so if you say so… I will try to contact iZotope, but I can easily imagine what would be their response (“Works in old WL and newest Cubase but not in the latest WL? Well then get in contact with the WL’s author”)

STILL, you could have told me this already 4 months ago when I originally reported this! I would have at least some response from iZotope by now for sure… :unamused:

It is very common, that a plugin changes its behaviour according to the active host. In theory, this should not be necessary. In practise, it is, because the specification has shadow areas, this is what happens.
I don’t know what happens with the Izotope plugins. What I know is what I already told you, and that this does not happen with other plugins (or at least, not with some that I know).
Sorry if I did not give an answer sooner.

So I got response form iZotope

As it was released recently, the current update of RX 2 is not officially tested and supported inside of Wavelab 7.

In general this is indeed the behavior of the plug-ins that provide keyboard support as ours do. When clicking inside of the plug-in and changing your computers focus to the active plug-in window, keyboard input will then be directed to the active window you have clicked in - in this case the RX 2 plug-in. If the active window is indeed Wavelab than keyboard focus will go to Wavelab.

If a keystroke is not being used by RX 2 or assigned to an RX 2 plug-in parameter, the key will be passed through and providing that it has a corresponding keystroke with the host application, will engage that parameter. We have not heard of this issue with Wavelab 7, however I will let our developers know to be looked into for possible future updates.

So almost 3 months passed and I still can’t use WL7 as my main editor as there is no update / fix from iZotope yet :unamused:

I noticed similar issue although I am sure this time it is WL to be blamed indeed.
In my dual screen setup if I click in Control Window (on my 2nd display) F6 shortcut does not work anymore although F7 and F8 still do. I have to click in the main edit window (on my main display) to make it work again…


The keys are “eaten” by Izotope, I can’t see a solution from my side.

? Apparentky you did not read my post carefully.

“I noticed similar issue although I am sure this time it is WL to be blamed indeed.
In my dual screen setup if I click in Control Window (on my 2nd display) F6 shortcut does not work anymore although F7 and F8 still do. I have to click in the main edit window (on my main display) to make it work again…”

This has nothing to do with iZotope e.g. F6 does not work even if NO plugin is used at all…

F6 is about playback of the active document. If the Control Window is the active window, there is no active document, as its window is not active. Hence this is normal that F6 has no effect.

Hm this is very unfortunate as I very often change settings, activate / deactivate various options (Master section, plugins, meters) and want to immediately check the affected (selected) part of the audio material. This is something that in WL6 was no issue at all.
I am sure you could change this behaviour as F7 and F8 still DO work and enabling F6 also when Control Room window is active cannot harm at all, and it only makes life more complicated and adds another (unnecessary) workflow difference between WL6 and WL7 making full transition to the latest WL even harder (not to mention lack of proper manual).

So please, enable F6 everywhere the same as F7 and F8 already are enabled.

F7 is a universal “stop”. F8 benefits from a “smart” treatment. I agree this is misleading for F6 then. I will see if I can do something about it.

I recall this shortcut F5, to switch to the last workspace.

@Johnny B Richman
Confirmed: “F6” changed included in next version.

Great! Thank you