J bar repeat function not working for me

This feature doesnt work for me (Win 10, v.4.0.031):

If you show the jump bar in commands mode after performing a command, your previous entry is shown with its text selected.

Hitting J always gives me an empty bar.

Is this another instance of my unique version of Dorico? :smile:

David

When you say “an empty bar”, what do you mean? An empty list in the Jump Bar menu? Or that Dorico is somehow inserting a bar into the project when you press the “j” key?

Clarification: I mean an empty list in the jump bar. Sorry!

I have now discovered that this only happens when I have no note selected in the score, which is often the case when I want to turn bar numbers on or off.

David

There were some bugs with the way this worked in earlier releases of v4 so deleting the existing jump bar history may help. On Windows this history is in the registry, at HKEY_CURRENT_USER\Software\Steinberg-Dorico4\jumpBarCommands - you can delete that key.

Richard,

there’s a whole folder of commands. Do I delete the folder?

D

Yes, that’s right, it’s a list of commands you’ve previously invoked from the jump bar. There were some problems with the way this information was stored, and, although we’ve fixed them now (I hope!) you may need to clear the list to start it working.

Closed Dorico, deleted registry entry. Now the problem is different:

I input Page bar numbers in the Jump bar: it works.
Then return (without selection) and the list is empty. Hit down arrow. Still empty. Dismiss J bar.
Select a note and hit J: J bar contains Bar Numbers (but below the selection box and not blue), down arrow does nothing.

Do I need to reinstall v.4.0.31.1060?

David

No, I suspect this is a bug on our side - I’ll investigate, thanks.

OK. Thanks for your help!

David

The Jump Bar does respond contextually to the selection. Commands that cannot apply to the current selection are omitted.

I had hoped that this problem might have been solved in 4.1; but when I press J, I get the previous command, though it is unselected and in order to highlight the command I have to hit arrow down, arrow up, before I can select and reuse it.
David