Jamstik doesn't operate in MPE mode

I have a Jamstik Studio MIDI electric guitar. I’m running Cubase on Windows 11. For the most part, it functions, but not in MPE mode.

They asked that I verify proper operation with their desktop software, which it does.
I am also able to launch it in the DAW in plug in mode, which it does.
When I enable MPE mode in the DAW it doesn’t function properly.

When I asked their support about it, they said:

"That sounds like Cubase is not preserving the MIDI channel info which will affect the guitar MPE patches that require specific MIDI channel info. Do you have any other DAWs that you can try it with? To confirm you can try the patches in the Jamstik Creator software standalone.

Please see this note on MPE compatibility regarding Ableton and Studio One (this must apply to Cubase, I will have to check the latest update and check to confirm if this but it sounds exactly like what you are reporting)

MPE Compatibility Note:
Ableton Live 11 and Studio One 5’s MPE implementation does not preserve MIDI channel information, which is used by the Jamstik to distinguish notes and events on different strings. This blocks the Creator from showing inputs from the correct strings on the fretboard display as well as routing notes from specific strings to the correct per-string samples or accurately replicating hammer-on effects. We have reached out to these companies and hope they will make changes to properly accommodate MPE controllers in the future.

The Jamstik Studio can still be used properly with MPE-compatible synths in Ableton Live 11 and Studio One that do not require un-scrambled MIDI channel data."

I’m wondering whether there are any settings that I have missed that might help me address this issue.
Any inputs are appreciated!

Thanks in advance.



Try Studio > Studio Setup. Click the + Add Device. Add the Note Expression Input Device, please. This is MPE, in fact.

1 Like

Also set the track to midi channel any instead of 1, that will preserve the incoming midi channel

1 Like

Thank you! I’ll definitely try this when I get into my studio later today.

I was definitely not aware of this @vinark – thank you!

I appreciate your comments and will report back. Thanks!

I was able to create the “Note Expression Input Device” and select the Jamstik.
I will call that progress, as I didn’t know about that before! :wink:

I created an instrument track and selected this device and the instrument (Jamstik Creator)
I also created a MIDI track and selected channel 2.

I’ve done both of these things and am still experiencing the issue.
At this point, I’ve captured the settings and will go back to Jamstik support to see what they have to say next.

Appreciate your comments! Thank you


Did you get this working?
I’m considering Jamstik, can you recommend?

Best regards,

Hey Juha!

Two things:

  1. Their software has just not worked well for me. Using the client in Plugin mode was a disaster when using Cubase 12. I’d previously tried it with Cakewalk and it killed the client. I don’t know if it is still an issue, as I’ve made the full switch to Cubase.
  2. Once I used Martin’s suggestion, I’ve been using my Jamstik Studio model consistently and I’m loving it. I use it with all sorts of libraries and synths and it’s exactly what I wanted! I’ve not found anything that I cannot do with it.

While I’m disappointed with their Creator software, the hardware has performed extremely well for me. If you are looking to use this with products from Synapse, Spitfire, Arturia, etc., I have no reservations recommending it.

Let me know if you have specific questions.


Thank you…just ordered pro!