Jump bar issue in v4.3.10

Hi there,
I just noticed that switching between the two jump bar modes with Ctrl+1 and Ctrl+2 does not work in the recent Dorico Pro update. Is anybody able to reproduce this? I am on macOS Catalina 10.15.7…

This works as expected for me. Have you overridden any of the default shortcuts?

Hi,
for me it doesn’t work either. I’m on macOS Monterey 12.6.1 and Dorico 4.3.10.
Thanks for the hint, @DanielMuzMurray

1 Like

Hi Daniel,

I just restarted my computer, but it is still not working with the default shortcuts. I have not overridden the default shortcuts, but the commands were unassigned to any shortcut. I now reassigned Ctrl+1 / 2 to the jump bar modes which obviously did fix the problem.

Mayday… it fixed the problem in 4.3.10. After the update to 4.3.11, even the manually assigned key commands Ctrl+1 / 2 will not work within the jump bar. I tried to assign it to a basic filter command and it does not work either. I suspect it has something to do with german keyboard layout. Interestingly, Dorico recognizes those shortcuts correctly while I assign them to a command though.
I have not changed any system-wide shortcuts either…

There’s been no change in the way the shortcuts work, neither in Dorico 4.3.10 nor in Dorico 4.3.11, which literally has a single change compared to Dorico 4.3.10. Control-1 and Control-2 are essentially hardwired into the jump bar’s controller, so they should always work. Try moving your custom shortcut file (in your user app data folder) out of the way, then restart Dorico. Do the shortcuts now work?

I just updated to 4.3.11. I made a new observation. When I create a new file, the key commands do work. But when I open an older file (started prior to 4.3.10), the key commands do not work.
I tried it with several older files. Same result.

Daniel, I also tried you suggestion to remove the custom shortcut file. Same as before. Works on new file, doesn’t on older files.

Additionally I want to second piano_jochen’s thought - I use a german keyboard, too …

I just tried it with a newly created file. Still not working for me.
Removing the custom key command did not help as well. There’s something quite strange going on…

In Windows 10 I was finding that, once in Go To mode, I had to press Alt-C twice to get back to Command mode. But then I noticed that the 4.3.11 update was available, and having updated I find that it now works fine. I have a UK keyboard.

I’m on Windows 11 (German) with a German keyboard. When I open the Jump bar and change to “Gehe zu” with Alt + G, it works fine. When I want to switch back to “Befehle” Alt + B opens the “Bibliothek” (Library) because it has the same shortcut assigned to it. Perhaps this could be changed. It probably has to be Alt+ L, because all the other letters of “Befehle” are already assigned to a menu or to switching the hand tool.

Hi Daniel,

I finally had the opportunity to update my macOS from Catalina to Ventura. (yes, it was about time…)
Switching modes in the jump bar with the default keyboard shortcuts is now working again, yay! The issue might have been caused bei an obsolete framework in my former OS. Just wanted to let you know…

Have a nice week!
Jochen

1 Like