Jump-Bar shows wrong shortcut

The jump bar shows me the shortcut for swapping the content of staves when choosing “swap content of voices” (for which I have no shortcut set). But choosing “Swap content of voices” performs as expected.

Here some pictures:

Jump-Bar entry with “swap content of voices” shows option-v, s as a shortcut

This shortcut doesn’t work, and neither does it show in the context menu (“Stimmeninhalte tauschen”, 3rd from below):

… which is no surprise, as it is assigned to paste special > swap (“Tauschen”, second from below)

Could you please attach your keycommands_de.json file here?

keycommands_de.json.zip (1.2 KB)

Looking at it, I see that “Swap Voices” is defined as “option v, s” as well.
I don’t remember setting it, but I might have in a dark moment. Should Dorico not warn me, when doing so? Or delete the other shortcut from the command?
I assume it’s as easy as deleting the entry in the .json to fix the issue?

Still interesting it didn’t show in the context-menu, though.

Sorry to take a while to come back to this one. Yes, you have the same shortcut defined in both the “global” and “music editable” scopes. You normally want to avoid this kind of duplication. Scopes like “Write mode” and “Engrave mode” are of course OK, but when you have both the “global” and “music editable” scopes, things get a bit less deterministic.

1 Like