'Jumping' of the cutting tool in Cubase 11 Pro midi editor

I am finding that when I use the cutting tool from the toolbar within the Midi Editor the following happens; say I want to trim the track at point 4. Using the cutting tool (scissor icon) I click on the desired time line cut point whereupon the cursor jumps to another place entirely say four or five bars further on. I then have to manually return to my desired cutting point in order to carry on, deleting the previous section for example. It does no seem to matter if the midi notes have encroached beyond the time line or if the are entirely within the bar. It’s driving me nuts and causing real issues with my work flow. Can anyone help please?

Hi and welcome to the forum,

Try to disable the Transport > Use Video Follows Edit Mode option, please.

Hi Martin,

Thank you for the rapid response. I found that *Transport > Use Video
Follows Edit Mode was actually already disabled but out of curiosity I
enabled it instead and**voila! That has solved the issue
.**