Keep velocity at original level

Is it possible in Dorico to keep the velocity of the notes at the original level they were played? As soon as I play back my music, all notes are set to 100, which is especially annoying in piano parts. There’s the possibility to do reset playback overrides, but this means extra work for every passage I just played in Dorico, so it would be great if it could be set in the playback options f.e.

If you use real-time recording, you should find that the velocities of the notes are reproduced as you input them, but if you use step-time input, velocity is not considered.

I still haven’t experimented with real-time recording but from the reports here it really sounds promising. Just wondering, if one has entered notes using this method, can one reset the velocity to 100 after the fact to remove any unwanted irregularities? Another question, how does Dorico treat the combination of entered dynamics and the velocities of notes entered in real-time?

To set the velocity to 100 for your notes you just have to select them and change the velocity to 100 in the play window.
The treatment of velocity and dynamics is more related to the used library then to Dorico’s way of handling. F.e. if you have the sample modeling brass and velocity of the note is 100, you get a clearly audible accent on the note, but at 80 the attack is much more relaxed.

You can do Play > Reset Playback Overrides to remove the played performance of the notes you input in real-time, or those that come from MIDI import.

I created this topic about half a year ago, but I still run into the same problem. Now I was able to capture it on screen, so I thought to give it another try.

Anyway, the video shows that once some notes are entered, as soon as you hit playback (either spacebar or ‘P’) the velocity jumps up to 100. It really becomes a timeconsuming job to reset this all the time, also because I use several libraries that respond very much to note velocity like Aaron Venture Infinite Woodwinds and Brass. Not to mention that most libraries use velocity instead of CC for the volume for short notes, so it’s a bit of a PITA to have to reset this in the editor all the time.
Velocity change on playback.rar (290 KB)

Please see this earlier post that describes a couple of the relevent preferences and commands: https://www.steinberg.net/forums/viewtopic.php?f=246&t=149054&p=826854&hilit=remove+overrides#p801443 . That describes playback positions, but the same principles apply to note velocity. In summary:

  • If you use MIDI recording just as a means of getting notes into the score, you probably want ‘Preserve note positions’ and ‘Preserve note velocities’ off
  • If you use MIDI recording to capture a performance and you want to hear the same timing and dynamics during playback then set the Preserve options to on.

Hello Paul,

Thanks for getting back to me.
I’ve tried what solution you pointed me at, but it doesn’t really make much of a difference; I really exaggerated the note input with the caret, so no live playing or whatsoever (will get back to that below), from very loud to almost inaudable. I kept an eye on the Play window while entering the notes, but all notes were set to a velocity value of around 64, whilst some notes should represent the value of very soft, or be almost at the max. After hitting playback, velocity changed a bit more to the way I entered the notes, but still all notes stayed somewhere around medium velocity values.
After that I changed preferences in the Playback options and set Beat stress and Humanize dynamics to 0% and now all notes, no matter how soft or loud I entered them were automatically set to a velocity value 64. Setting Beat stress to 1 and Humanize dynamics to 100% only resulted in higher velocities, but nothing close to how I entered the notes.

Then, when played live, all of a sudden everything worked as given in the solution. Now, that’s a good thing by itself of course, but since I’m a composer who works from screen and relies on notation and is not a very good keyboard player, it would be great if entering notes with the caret could give the same result.
I must say, experimenting with quantization settings and deselecting preserve note positions, was a step in the right direction, but still I would highly prefer that notes entered with the caret would also keep the values as how they were entered. Can you tell me if this is possible at the moment?

No, it’s not possible. Dorico doesn’t take any notice of note velocity during step-time input.

Hi Daniel,

Thanks for your reply, then I know what to do to get this captured.