Key Command / Macro help

I can’t solve this one. Any ideas?

On the project page, I want to select a single track, enlarge it vertically (very tall), do my editing on the midi/audio parts, then shrink the track back to its original size, in keeping with the row height of all other tracks.

I’ve tried various zoom techniques, but they don’t quite do the job. The closest I got was (top toolbar) Edit, Enlarge Selected Track. (I also assigned a key command for this in File, Key Commands, Edit.) The problem is that I can’t quickly shrink the track back down without going back to Edit in the top toolbar. In File, Key Commands, I tried to build a Macro, but I couldn’t locate an undo command for this. I can enlarge the track, but I can’t quickly remove this setting. Maybe I’m overlooking something.


There is a KC called “enlarge selected track” in the Project & Mix console KC folder. (I think it’s called that I’m doing this from memory at the moment). It’s one of my most used key commands.

You could also do this from the preferences section, but if you did, every time you select a track it would be enlarged. What I think you want is to select a track and then the option to decide if you want it enlarged to a pre-set width? If so use the key command.

In this mode, use your key command, then set your width just like you have been doing.

Now your assigned KC should always open/close that track to your set width.

Keep in mind if you change tracks with this KC open the track you select will automatically be opened to the set width. To go back to normal, just hit your KC again since it acts like a on/off function.


“Enlarge Selected Track” Key Command is under the Edit folder in KC. What I like on this solution is, you have 2 sizes of your tracks, in fact. One size is “!enlarged” and the second size is “normal”, Then you can easily switch, which size currently selected track has. So once you set the size of your “enlarged” track is 10 lines, then every “enlarged” track will be 10 lines large, until you change it. So it remembers its size as a general settings.

Try working with events and range selections instead of tracks.

The ‘Zoom to selection’ function is a good way to zoom in to the current selection (key command: ‘Alt+S’). Use ‘Undo Zoom’ to zoom back out again (key command: ‘Alt+Z’). You could try assigning ‘Z’ and ‘Alt+Z’ to these commands.

Zoom to selection works with both event/part selections and range selections.

Or just use ‘Zoom Selected Tracks’ in the zoom menu.