Key commands for Set Locally/Globally not working

Can anyone explain why the key commands I’ve got for Set Properties Locally/Globally might not be working? (2.0 KB)

After doing “Press shortcut”, did you click “Add Key Command” and then click “Apply”?

Also, maybe try different key combinations.

I was able to add keyboard shortcuts for those two commands without any problems.

Yep and yep.

Just tried two different combinations, both in Write and Engrave Mode. I also tried MIDI Commands.

What shortcuts did you use if you don’t mind me asking?

I’m on a Mac, so the modifier key assignments (especially “Meta” and “Ctrl”) might not translate exactly to Windows.

I used Cmd-Alt-Shift-G for Global and Cmd-Alt-Shift-L for Local.

A screen shot of the relevant part of my keycommands_en.json file looks like this:

Same here (except for the actual key commands). Are your entries up the top of the json file, in the “Global” shortcuts section?

Yes. A few lines down from the start of the “context” : “kGlobal”, “shortcuts” section.

Cool, thanks anyway.

Do your other keyboard shortcuts (in that json file) still work OK?

Yep, they do.

Hmmm. The plot thickens.
Apart from quitting and re-opening Dorico and maybe even restarting the computer, all I can think of is that maybe your System is using the key combinations you have tried and won’t allow them for anything else.

The Dorico restart did it. Thanks mate.