Key Commands from Contour ShuttlePro v2 not working

I have the shuttle knob programmed to send key commands to perform the following tasks:
1.JPG
It worked and still works in Cubase Pro 8.5.

In Cubase Pro 9, Cubase “sees” the first shuttle knob keystroke and the command “Shuttle Play 1/8x” works. If I turn to the next position, playback stops. It should be doing “Shuttle Play 1/4x”. If I move to the next position, it does “Shuttle Play 1/2x” as it should. Moving through the rest of the positions, it skips every other position.

If I look in the Key Commands dialog box while turning the shuttle knob, I can see that Cubase is seeing the keystrokes, but not executing them like it did in Cubase 8.5.
2.JPG
All of the other buttons work as programmed.

I’m attaching the .pref file with the Contour Shuttle Device Configuration that I exported.
Cubase Pro 9 Settings.zip (720 Bytes)

Thanks for posting, I’m having the same problem. Also, is there any way to just have the ShuttlePro v2 show up as a controller like an HUI device?

That would be a nice feature.

This is bad. Along with the many other reported bugs, it is clearly way too early to spend money on C9.
I’m not going from a rock steady C8.5 to a wobbly, buggy C9.

Too bad no one from Steinberg has replied to this.

I have had CP9 crash on me several times. Is there any word of an update to fix these issues?

No fix from Steinberg means I cannot go for C9. I am relying a lot on the Contour ShuttlePro 2, and was actually considering purchasing a CC121 as well. In another thread it seems this one doesn’t go well with C9 either. Steinberg, please fix this. Your statement about Cubase being the most stable DAW is a blatant lie all regarding C9, only 8.5 is worth the money.

Hello,

I have the same problem. I did the Key-mapping for the shuffling in Cubase and in the Contour-Software. The Shuffling work some times. If you have selected one speed and it works it will work until you change the speed to slower oder faster.
What I figured out. If you press the same Key-Commands, which schould do the Shuffling, on the Computer-keyboard the shuffeling works except if you press in between two keys an the same time. And I think that is, what the controller does.

BUT same configuration worked in Cubase 8.5.

Cherss
Onkelrichards

It does not seem like the problem is with Steinberg because if you try the actual key commands in cubase it works perfectly.

I have the same problem with my shuttle wheel. Here is my other forum post:

I can confirm that the Shuttle Pro V2 driver does not work properly with the jog wheel in Cubase 9. It did work perfeclty in Cubase 8.5. Everything else works, except that. I tried reinstalling the driver, as well as everything else you said.

Can you guys please work on a fix for this asap? I love the Shuttle also, and it is a real shame that it does not work properly on Cubase 9.

To confirm it is a problem with the Shuttle driver.

I have Shuttle Zone 7 set to hold key Control+Shift+7 to Shuttle Play 8x in Cubase 9. It seems to work perfectly in the Contour Shuttle settings program. When I hold Control+Shift+7 on the keyboard, it also works perfectly in Cubase 9. However, when I operate the Shuttle in Cubase 9, it does not work.

I hope you guys can solve this soon. Thanks! :slight_smile:

Also, I am on Mac Sierra 10.12.3.

Hi there …

same problem here.

  • Windows 7 Professional 64 bit
  • Cubase 9.0.30
  • ShuttlePro drivers 2.13.3

“normal” key assignment works, butt Shuttle does not. Anything I assign works perfectly in Cubase using keyboard, but not in Shuttle.
I do not know if the problem is on Cubase or ShuttlePro side (I have a request open at their forum, too), but this is an annoying problem.

Best regards
Bombasstard

Hi,
same problem with Cubase 9.5 and ShuttlePro driver version 3.0 (3.0.39) on iMac…key assignment doesn’t work also.

It is not related to the shuttlepro. It is there for generic midi as well. On generic midi it seems that you need to wait about 150ms between
transitions of different play-speeds. PlayForward1/4 -> sleep 150ms -> PlayForward1/2 works (mostly)

I think it might be the same problem as with this:
https://www.steinberg.net/forums/viewtopic.php?f=253&t=126766

Pretty amazing. This issue was reported by PryorCreek 09 Dec 2016 06:31. They will not be able to fix this within a year? For some reason I think transport is fundamental for a DAW. Sort of like a car maker that does not respond to reports that steering wheel is not working.

agreed…i really dont understand steinberg sometimes…this so crucial almost fatal for a studio healthy workflow…i begin to thing that this is done on purpose so we buy the CC121…no it cant be, anyway i found a little workaround on the attachments hope it helps
1Cubase Pro 9-stand-by.rar (653 Bytes)

Any news on this subject ? Solutions, workaround ?
Should i sell the Shuttle Pro and buy a CC121, or an avid transport (would be a pity !!)

Maurizio

Not sure if I get the issue right, but post this anyway.

When I got Shuttle Express - I could not get it working - in any program that is running as Administrator elevated state.
So if this is your case - just run Cubase as normal user. You can belong to administrators group and all that - just don’t run daw in elevated state.

I did it most out of rumours that some plugins authorizing is not working and similar.

I talked Contour Design about this 4-5 years ago - but they never attended to this, or it’s not that easy to fix.

Anyway - Shuttle Express always worked really well for me - in various daws, and other software too.

The Problem with the Shuffle Wheel stopping exist still in Cubase 10.
I realized that the problem is, if you lets say key “a” is shuffle 1x and key “b” ist shuffle 2x and you press the keys on the Keyboard they work ecxept you dont releas “a” before pressing “b”. And I think this is the Problem with the ShuttleExpress if you shuffle the Jogwheel. If you turn the wheel the Keys are overlapping. So I solved the problem leaving out every 2nd shuffle-Definition at the configuration fo the ShuttleExpress.
Thee are 7 position to assign and I olny assigned 1,3,5,7., this make less values, but at least it works

Rather than remove “As Admin” from Cubase, I found that by setting ShuttleEngine.exe and ShuttleHelper.exe to run “As Admin” it all works fine. They live in the Program Files\Contour Shuttle folder.

This shows a lot of professionalism, is a pleasure to read this. Thanks for the post.