Key Editor grid not using selected groove

Hello,

I’m using Cubase 11 latest. I’m trying to use Cubase groove features to write MIDI, but for some reason, the ruler grid isn’t using the groove I’ve selected.

See screenshot below. On the left, you can see the intended groove. On the right, you can see I’ve selected Bars + Beats and Bars + Beats Linear as required.

Hi,

The Ruler doesn’t show the quantize settings. It shows either the Bars + Beats or the Timecode, or whatever you set.

The Grid shows the pattern.

1 Like

Hi Martin, thanks for the reply. I’ve corrected the thread title as per your comment - you’re right in that the behavior I want is for the grid, not the ruler, to reflect the groove.

Unfortunately, I have to disagree, I don’t believe I’m seeing the Key Editor grid use the groove either. You can see there are differences between the grid and the groove on the left. For example, both measures of the groove feature a note on beat 2, but there is no vertical line in the grid on beat 2 of the first measure.

This behavior would be very useful for drawing MIDI.

So, just to assure you that the standard behaviour is as Martin described it…
I drew in some midi notes and created a Groove Quantisation preset out of it. The grid lines are exactly where the notes are and where the Display Grid indicates they should be.
This is version 12.0.40

I am poking my brain why you get a different result. I do not recall this being a problem of version 11. Maybe it is a zoom issue? Do the grid lines change when you zoom in or out?

Hm, interesting. So I’ve given your flow a shot - it looks like the pencil abides by the groove; it’s just that the grid does not show many of the groove’s hits. Is there a setting for making the grid more or less granular with respect to the groove?

See video here: imgur .com/QZ58qPr

Have you ruled out corrupt prefs?

Do you need this (below)? (I don’t remember whether that’s needed or not to present the grid according to groove)
Use Metronome Click Pattern Level for…


and

1 Like

It’s not. In fact the two features are mutually exclusive.

@ahorsewhocandrive Have you done that?

Sorry, I’m unfamiliar with the corrupt prefs concept, is there a reference I can use to learn? And is there a specific preference that affects this behavior?

Ah – yes. The sequencer provides a way to do some basic troubleshooting, check out starting in Cubase Safe Mode with disabled preferences - Google Search.

Opening with “Disable program preferences” produces the same behavior:

It is actually working in your screenshot. The grid lines are quite dark though against the background, so you may not be able to see it.

You can change the color in preferences here:

I can see the lines; I guess what I would like is for all the lines to be present, whereas currently, only a few of them are.