key_editor lanes not aligning to keyboard

hi, I have experienced issues in C7, that when I click into the Key::Editor, the notes in the window-frame are
not distinguishable as their intended note-names. Indeed, even the graphical lines that are meant to align
back to the keyboard diagram on the LHS vertical margin, are not even correctly rendered in the key-editor.
I am not sure if anyone else has had this issue when working with C7.
I hope Steinberg are aware of it, and that we also get a resolution to this too.
Key_Editor_no_alignment.png

not here or didn’t understand your problem: if i selecte a A2 note everywhere a2 is a2 : vertical keyboard on the left, on the grid, on the horizontal info line above
Are you sure that you don’t interpret as the background is dark the horitontal black line as black keys?
like on a blackboard black keys are white

I’m not exactly sure what I am looking at there, but the highlighted A2 in the grid does look to be horizontally in line with A2 on the keyboard. On the other hand, I see, on the keyboard, B2 highlighted, but that is merely reflecting the current position of your mouse, which isn’t shown in your screenshot (and not the selected note in the grid).
Anyways, you can improve the “look” of the grid, in Preferences>Appearance.

thanks for the replies.
I guess to better clarify my point:
On the LHS Y-axis we have a keyboard, made up of of the keyboard notes, both the black and white keys (ok they are really dark and light, and not actually b/w).
In the key-editor window pane, there are lanes(rows) denoting these notes. however the dark-lanes(rows) are not representing the dark-notes (ie sharps/flats) on the Y-axis keyboard image.

In my pix, I have hovered over the B2 with the mouse, and we can see it highlighted. If you look toward the right, into the key-editor, this is aligned onto a black(darker) row
Maybe this is only on my system/install of C7 , but I have not had this happen in any of the C3,C4,C5 or C6 installs.

Yeah, this has been discussed before. You can use the settings to get it the “right” way.

But evidently there is a rumor that this is corrected in the coming patch.