Key Editor not on cursor

Hi, When I double click on a midi event, the Key Editor opens on the part of event where the cursor is positioned. And that’s great…but now when i have Key Editor opened and I click on another event on different track, the key editor goes on the beginning of the event and not where the cursor is positioned. :confused: :open_mouth: .Is there a way to set it up so that the key editor always opens where the cursor is? :slight_smile: :question: I’m working on orchestral stuff with long midi events and if I want to edit something it’s pretty nconvenient to have to always search forward for the parts where the cursor is and where I want to edit stuff. :cry:


Unfortunately there is no settings for this. As a work around, hit the F key (on your computer keyboard) twice to switch the AutoScroll Off-On. Then it jumps to the cursor position.

Ohh that’s too bad…would be absolutely perfect daw if it had that function. :confused: But thanks for the tip…will have to use the F key until hopefully Cubase 10 recognizes this as something of value :slight_smile:

Has this seriously not been fixed. I’m pretty sure this worked din Cubase 8.5? I’m in 9.5 and it is jumping to the beginning of the event. It is extremely annoying!

If we mean the same, the behavior was in Cubase 8.5 the same.

Maybe closing any open Key Editor windows before double clicking on an event would be a workaround? I usually close the Key Editor window after I’m done with it and ready to move on to other track edits, so maybe that’s why I haven’t noticed this issue.

I agree, it would be a great feature for MIDI takes comparison.