Key Editor - vertical keyboard keys don't align with the note event heights as expected

Repro steps:

  1. Load Cubase 11 Pro.
  2. Create a New Project. In the Project window, create a New Instrument track. (For this repro, it doesn’t matter if you choose a Virtual Instrument or simply use “No VST Instrument”.)
  3. Create a MIDI Event in the Project window with the Pencil tool. Then, open the Key Editor in the lower zone or in a separate window, to edit this blank, new MIDI Event.
  4. Using either your MIDI keyboard (or the Pencil tool + mouse), record or write in a simple chromatic scale starting on C1 to test this bug.
  5. Zoom into the Key Editor slightly so that the vertical separation between horizontal note lanes (e.g. C1, C#1, D1, D#1 and so on) is easy to see.
  6. Hover your mouse cursor just below the C1 note event. Note that C1 on the vertical keyboard graphic (at the left edge of the Key Editor) lights up even though your mouse cursor is not actually on the C1 note event itself.
  7. Next, hover your mouse cursor on the C1 note event, but take care to hover at the very lower edge of the note event. Then, note that as you slowly move the cursor up towards the top edge of the C1 note event, on the vertical keyboard graphic, you will see that C#1 lights up “too early”.
  8. If the user clicks the C1 note event with the cursor in this position (where C#1 is lit up on the vertical keyboard), Cubase erroneously thinks that C#1 is the current active note, and will try to trigger C#1 instead of C1, confusing and frustrating the user. This is a significant and chronic problem when working quickly in the Key Editor because the only workaround is to “aim lower, sometimes completely below and off the actual note event” when selecting note events with the mouse, which is quite unintuitive.

Expected behavior: The note highlighted on the Key Editor’s vertical keyboard accurately reflects the specific note event currently visible under the tip of the mouse cursor.

Additional notes:

  • The problem persists whether or not HiDPI is enabled or not.
  • I found replies to an old post from 2012, which suggested a workaround using Preferences settings, but those settings, called “Work Area”, no longer exist in the current version of Cubase Pro 11.

System details:
Cubase Pro 11.0.41 Build 448
Intel i9-10900K CPU @ 3.70GHz
128 GB
Windows 10 Pro (version 21H1, OS Build 19043.1348)


1 Like

Thank you for reporting this issue in such a professional form.

For devs Only: A similar issue was reported under CAN-32949