Key editor view problem

Hi folks!

I’m using cubase 5 on windows 7.

When I select a midi part in the arrange window, then press “enter”, the key editor pops-up. Nothing wrong here… The only thing being that, in the arrange window it shows bar 24 to 29, in the key editor I see bars 16 to 21. Even If I have Autoscroll “on”, I have to make additional mouse clicks to get my view to actually see bars 24 to 29.

See the snapshot attached as an example.

:question: Is there a way to always have the Autoscroll working even when switching from Arrange window to Key Editor window?

Thanks in advance!
Carl
key_editor_problems.jpg

Me again :slight_smile:

Many of you read my thread… No one experiences work flow slowing down with this Key Editor autoscroll problem?

Maybe I’m just too picky here…
:nerd:

Is there a preference “editors follow project cursor”?

Hi Brains,

Page 343 of the manual, it is said that the Autoscroll buttons in each MIDI editor are independent
of the Project window Autoscroll setting. Regardless if I turn on or off the Autoscroll button in the key editor, I always have to press the “F” key for the view to find the cursor when I switch from “arrange” window to “key editor” window.

It’s also important to know that I’m not playing back when I perform these edits in both window modes.
AUTOSCROLL_MANUAL.jpg

This is the way it is. It always shows the previous bars and there’s no way to change the behavior. :imp:

What would you suggest Steinberg do?

Anything or nothing?

Although I can see why it’s like it is, for the way I work I’d rather it display what’s to the right of the cursor. The way it is, it’s designed for if you’re listening to a piece, notice something to edit, hit stop and open the editor and the edit spot is on screen.

Yes but that does not help if you want to edit while listening.

Autoscrolling on suspend was a good start but more needs to be done otherwise the accusation that can be leveled at Steiny can be one that they themselves don’t use the application (often) enough and are therefore patently out of touch.

Digital Performer lets you option-click in the time ruler to move the playback cursor to that click point. Very nice.

The way it is, it’s designed for if you’re listening to a piece, notice something to edit, hit stop and open the editor and the edit spot is on screen.

In my case, here at least, this is not how Cubase behaves. I’m playing back something, hear something I’d like to edit, hit space bar, select the midi clip, hit “enter”… What I see in the key editor is not the spot where I stopped the playback… Sometimes it displays exactly where I stopped, sometimes it’s way off.

Does the zoom level in the Key Editor have any effect? Using the Inplace Editor is a workaround.

I don’t think it’s anything to do with autoscroll actually, since what you have pointed to likely only relates to the editors themselves and not the project, let alone managing the "transition’ from window to window.

I have always wanted a preference that allows you to click anywhere on an event in the project page and immediately you are brought to that point in a piece regardless of where the actual project cursor is.

In other words the project cursor should not be the be all and end all of using a linear sequencing application.

I have always wanted a preference that allows you to click anywhere on an event in the project page and immediately you are brought to that point in a piece regardless of where the actual project cursor is.

That’d be awesome. Totally agree.
Maybe a preference added in the next version of Cubase 6 :wink:

There’s a Pref to Locate When Clicked in Empty Space. When I enable this in C4, when I open the Key Editor, the cursor is in the middle of the screen and bars before and after show.

OP;

I’ve been using a Macro command to resolve that issue. It works for me now.

I attached a capture of the actual macro if anyone interested.

Cheers.
Cubase Macro.jpg