Key Editor won't open

Have you tried just clicking on another track. Then back to the MIDI track?

I have seen some issues with Windows management in C8 but never something that would make me hate it or reinstall. I do not use much MIDI stuff so I am not really the guy to talk to.

From what I have tried, it seems to work fine for me. I do have 3 video monitors and a quite powerful PC. I am sure that there could be issues with other setups.

Best wishes for you man. :slight_smile:

I would contact Steinberg support.

I have.

Although, to be frank, I am still waiting for a reply to support request made in mid-December.

:imp: :smiling_imp:


I tried it today but it didn’t work for me sadly.

Hey thanks. I tried different fixes as well and the issue is still there. I also can’t rename instruments in the rack and some other functions. Yes there are work arounds but when I’ m working…sucks to have to stop and do too much thinking. Definitely a bug in Cubase 8. I’ll give Steiny a pass on this one though since they’ve done some great things. I’m sure a fix will be in a future update.

I have the same problem with the drum/key editor. I had to assign a keyboard shortcut as a temporary workaround.
I never had this problem in 7.X using the same workflow.

To be frank you should have received a email reply if you live in the USA within a couple days. Other countries have phone support.

Perhaps check your spam mail or call them if you don’t live in the USA?

I’m assuming they either know about the problem or already know and are working on an update. They seem to do a very good job (lately) of fixing their bugs.

I’ve been doing SW development since the 1980s, and its been my experience that if you miss a deadline, a year from now nobody will remember, but if your users have some stupid bug that keeps popping up in your face everyday as a reminder, they will remember that. That’s my message to the suits in charge of scheduling and product roll outs… :laughing:

I can confirm this bug. Cannot open any editor with double-clicking on the MIDI/audio part as it used to work.

That is just strange that it works for me as it should.

Must be a bug related to some setting or something…

whats even stranger, is that it is non consistent. For me it works about 10% of the time, but in the last few days I’ve retrained myself to just go to the menu MIDI>Key Editor, which works every time.

It’s not very reassuring of the underlying code

same here. I can’t focus on working, because everytime I want to open editor or rename track, I’m stuck… please fix it soon

I’ve gone back to 7.5. Had enough of 8 and the problems.

I’ve had this happen, can’t double click to create a midi part or open the key editor, drove me nuts for a while, quite and ran another program and all worked fine, went back to C8 and was still not happening so after changing mouse and driver to no no avail decided the problem was in C8. It was in a template I’d made. However loading another project in, all worked fine so not sure what’s going on.

I still get this problem btw, it doesn’t happen always, though. However, it never happened in 7.5. I’ve got a list of 26 problems now, some more severe than others, quite a few show stoppers though. I do not trust the code in 8, or the testing and QA before release. I’m back with 7.5.

Upgraded from cubase 7 to cubase 8 in mid december 2014.Have found a solution for opening the editor. I noticed after double clicking the editor would not open but observed that a shadow appeared over the cubase icon on the task bar.I clicked on the shadow and found the unopened editor underneath the icon …clicked the maximize window button and this has solved my problem the editor now opens when double clicked hope this will help someone

Can’t offer a difinitive solution but in my case it was down to the mouse driver. I reinstalled my mouse drivers and the problem (at least for the time being) seems to have abated. SB obviously recodes the mouse functionality (e.g., Note facility) so its possible some slighty buggy code may exist.

just mention it: installing sequel 3 also kills the key editor, and can freeze out the whole application, only a big white window was popped up, trashed out the preferences solved it (I also uninstalled sequel before) win8.1, 32bit

I’ve been having intermittent problems with this, but today it’s especially bad for some reason. It affects all double click functions, including opening the key editor, creating new parts and events, renaming tracks, setting the locators to a cycle marker etc etc. I can rarely get any of these things to work at the moment.

Edit: clicking repeatedly without moving the mouse or doing anything else eventually brings the function into effect, but it takes tens or hundreds of clicks.