Key switch on first note doesn't take

I assume you already know about this one. But the first note of the first measure with a key switch doesn’t seem to take. I’'m adding a blank measure to work around this for now.

Do you get this with the Dorico default playback template (SE and included expression maps)?

I ran into a similar or identical issue here. I sent Daniel a report/logs/project/etc.

In my case it worked fine when using Dorico’s default playback template, but with Garritan Personal Orchestra 5, and my own home brewed expression map, my pizzicato technique applied to the first note in the score works only/exactly 50% of the time.

That’s interesting… I don’t have this problem with any Xmap so far… be it Halion, Kontakt, Garritan or VSL… any details…?

Here’s a copy of my report:

On issue 4, here’s what Daniel had to say so far, and I still owe him some tests and correspondence.

No, I was using Vienna Instruments. The specific case that was a problem was pizz. on strings. It would seemingly work if I stopped when pizz. was already playing. But if any other technique was selected then the fist note would not switch.

I have a theory about what could be causing this: could you try going in to the Playback options and in the timing section set the humanise to 0. I think it’s possible the note is being triggered before the keyswitch. It’s a known issue that we’re trying to find a good solution to.

Same here, when using Vienna the first note keyswitch is not triggered. When using Dorico default (Halion) it is.
humanise to 0 doesn’t help.

I may have spoken too early… I get the same with VSL (Having just started a new virgin project in 0.30)

Paul, if you are normally doing key switches just before the bar for the first note in a bar, then maybe in the first bar the key switches are happening at the same time and this isn’t enough for some third party libraries.

The funny thing is that Vienna Instruments pro is probably the best performer in this area, much more responsive than kontakt in my experience. Visually the articulation is selected «way before» Dorico outputs the sound…

Hmmm. Might be a function of how large the expression map is. The ones I am using are huge.

Edit: Nope that’s not it. Just made a minimal one and it exhibits the same issue.

I think this is explained by buffering. The sound comes later because of the buffer. But the key switch and the note events occur before the buffer. So if they are asserted at the same time (or possibly even reversed from what is intended) you can’t see this unless you look at the time-stamped midi stream. And how do you do that in Dorico. There is no midi out so you can’t trace it.

So I made a test case with a 1/1024th rest before the first note and the pizz. plays correctly every time.

We do output the key switches about one midi tick before the notes that use them which should be enough for most sample libraries (note that these events are time stamped so it will strictly receive them in order). Maybe some libraries need a finite amount of time to respond to a keyswitch? Is there anything in the user guide of the library you are using that indicates a specific time delay? It may be that we need to expose an option for this. However, I’m not aware of any problems with Cubase users of expression maps, and I think those are output at the same time.

One thing you could try to diagnose the problem is to export to MIDI, as the timing of the events should be identical to in playback. Or you could upload a minimal score that reproduces the problem and we can take a look at it. (though please note I’m not going to be in the office for a week)

I output the midi stream and given the resolution of the sequencer I used it looks like all the events come at the same time. But in the right order. Program change, then key switches and cc’s if any and then the note.

But the difference the first note sees is a program change in addition to the key switches. This doesn’t occur again for a given instrument (assuming no instrument change). So maybe the program change takes longer to complete and is wiping the result of the key switch on this first note.

And by the way, it’s common practice in sequencers to add some time at the beginning to set up things. So if most/all users of Cubase do this, then they’re not going to see this issue.

Here’s a file that exhibits the problem. If you restart after playing, make sure the second note is played before restarting. (296 KB)

So, just for the record, a similar file as posted above works fine in Sibelius 7.1.3.

The odd thing in my ARIA case is that it works EXACTLY 50% of the time on the even starts.
First try: Broken
Second try: Works
Third try: Broken
Fourth try: Works

I haven’t had a chance to load things and test further yet, but hopefully today I can run a few tests through Bidule and record the MIDI Stream.

Interesting, can we use the Play Mode’s MIDI key-editor to drag-shift the note-on position without effecting the printed score in the yet? I’ll give it a try next time at my Dorico inspired workstation.

To test a theory that temp vs toggled Key Switches could be a problem:

I ran a test where I’ve swapped Halion Symphonic Orchestra (HSO) to use sticky key-switches instead of temp style.

With Halion SE and Halion Symphonic Orchestra things are working fine here.

First I toggled off temp key switching in SE/HSO.

Next I made an expression map for this test that would work like the Garritan Libraries require.
In this case we always need to send a default ‘natural’ technique key-switch to get back to arco.
This is how Garritan Library key-switches work.

It’s working as expected with SE/HSO, even with the sticky style key-switches set in HSO. This seems to rule out my theory that the sticky-type key-switches as used in Garritan Libraries may have been the soul culprit of the issue I reported earlier in the thread.