Key Switches on Expression Maps not working

I just upgraded from CB8.5 to 9 and I’m working on a project that have expression maps loaded. In CB 8.5 I can change articulations by pressing the correspondent key on my keyboard (i.e. C#-2) but this is not working in CB 9.

Anyone having the same problem?

If this doesn’t work in CB9 I will stick with version 8.5 and ask for a refund…

They should work the same. Perhaps you can post a screen grab of an Expression Map setup.

If you put a MIDI Monitor on a MIDI Insert does it show the C#-2 being transmitted? Are you perhaps using the Input Transformer? Hard to know what might be going on without more detailed info.

It is possible that the base note (bottom-left of the Expression Map Editor window) has reset.

I’m really sorry to interrupt the OP question, but I kinda have a problem with similar thing as stated in the topic subject, but not exactly the same as what the OP has described in detail. If you think I shouldn’t ask here, feel free to ignore my question. My issue is that when I set up my expression maps, they keep the first expression pushed all the time and every time I change an expression in this map I can hear it play the instrument that is connected to that track which creates some issues when I have keyswitches for instrument A from C0 to F0 and for instrument B from C6 to F6, but instrument B also has playable notes in range of C0-F0. So what happens when I load the project and I don’t have the right connection on that track, I immediately hear the C6-F6 KS instrument play, right ater I load up the project and don’t press play. So my question is - is that a normal behavior? And follow up question - is there any way of fixing the expression map in a way that the first keyswitch is not being pressed all the time but only when I press it on keyboard or write it in a key editor? I tried switching the Latch-mode but it seems to have no effect on this problem. Thank you and sorry for stepping in with my own problem.

P.S.: As for the OP :smiley: I agree with raino, have no problem with what OP describes and it looks like only a matter of wrong setting in the expression maps.

@ArchimonDe
very quick reply :wink:… without studying your issue in detail, sometimes the “first slot” (which is always the default slot) problem can sometimes be gotten around by simply creating a blank setting for the first slot.

Could it be latch mode enabled in C8.5, but not in C9, so that the KS only works when the key is held? (Expression Map Setup)

Nope, it’s enabled.

Here it is a screenshot of the Expression Map. In this case I’m using Play (from EWQL), but I have the same problem with Kontakt.

https://ibb.co/dhKgAF

As I said, if I open this project in CB 8.5 keyswitches work when playing the keyboard…

There is definitely a new bug in Expression Maps. I just spent over 8 hours trying to track it down, thinking it was in a problem in a Kontakt VST instrument.

Here’s the deal (at least for mine): Start with a new map, it’s easier. Create a sound slot, and some random articulation (I used “Test”). Now, in “Output Mapping”, assign a specific Note On as the keyswitch to be sent. For example, I chose C6, since my instrument was a (low-pitched) Bassoon, and its factory keyswitches were in that octave. Leave the “remote” field under “Sound Slots” blank (which the documentation says is OK, if you’re not intending to send the KS from your external controller).

Now, play a scale on your keyboard controller that includes C6. Watch the virtual keyboard in whatever VST (Kontakt, etc.) you are routing to to be able to see what keystrokes it is receiving. Every note will “play” except C6. That’s the bug (that I found). In my project, I had every slot from C6 to B6 assigned to a keyswitch except C# and G. For a day and a half, I couldn’t figure out why the only notes that would make it from the keyboard clear through to the VST instrument were C#6 and G6. Then, “aha”. But it gets worse. Take any instrument and in Expression Map, assign a keyswitch to a “playable” note (i.e., one in the instrument’s range). After such an assignment, that note becomes unplayable. You can put in a Midi Monitor and see the note being generated, but it never makes it to the VST instrument.

Workaround: IMHO, this is a severe bug, and needs an immediate fix. However, you can work around it by simply assigning the same key as a “Remote Key” under “Sound Slots” as you are sending to the VST under “Output Mapping”. Now, if you play it on your remote keyboard, it makes it all way to the VST instrument. WARNING: if you test this on a playable note, make sure that “Latch Mode” is off, or the note plays “forever” (I guess the way it “latches” is to never send “Note Off”.)

NB: If you should choose to use some other pitch for the remote keyswitch (for example, C-2) to trigger that slot, it doesn’t help; C6 is still wiped out.

Hope this helps someone. I’m not happy about now having to change 40 expression maps with nearly 12 slots each, to add in the workaround. But at least I can go back to writing music…

Exactly like I said… the “Root Note” has been reset to C-2 (MIDI note #0). You aren’t telling me that you have an external keyboard that can play C-2? (that’s C minus 2 btw :wink: ). I guess in Cubase 8.5, it is set to “C2” (MIDI Note #24)?