Keyboard command stays on

Hi again,
After assigning Halion (6, SE…) to a layer,
some keys doesn’t release after played and as a result a sustain effect gets in without any option to stop it (only by eliminating the layer).
that happens frequently also with the default layer !!!
I tried to use a different Keyboard and different cables- same for all.
Halion’s virtual keyboard shows exactly which keys are stuck each time.
Im using macOS.
any assistance will be appreciated,

Are you using USB keyboards? Maybe try a different USB port. Also, when you add a Part and change to that, are notes still stuck? Because that sends an all notes off command (as well as “Panic” does).
Never heard of this before. Check all details of your hardware.

thank you musicullum,
as you suggested - I connected two different keyboards,
tried each of them with a different USB port, switched cables,
reinstalled the VST live - but still the same problem.
Adding new part doesn’t solve the issue - Have to press panic.

BTW - I use this hardware on a regular basis with cubase and some other music apps and it works just fine, so I’m really confused.
any other ideas?

When you switch Parts, the same function as Panic is used (all notes off command). So at least add Part, play something, notes stuck: change to other Part should also silence droning notes.
You may also want to check Edit/Preferences/Layers/Sustain Seconds. But that should have nothing to do with that.
Should the issue persist when you change Parts, you might want to check your sustain pedal as well. When you change Parts, the previously active Part stays active until all notes have been released and the sustain pedal is depressed, plus sustain time seconds. But all of that does not explain why regular letting go of keys should not silence notes.

Not really, this is weird.

Switching between parts can’t really solve this problem and I agree - this is very weird.
the hardware issue can be eliminated since I launched cubase and everything works just perfect as always!
at the moment I launch VST live again the problem re-occurs immediately.
it might be a problem of Midi interface or compatibility to my keyboards - Yamaha and M-Audio.
I’m afraid it might be a software issue and unfortunately, until solved, I won’t be able to use it.
thank you anyway musicullum.

I would just really like to know if switching Parts kills droning notes or not pls?
The reason for insisting is that a standard MIDI All Notes Off command is sent to all MIDI outputs when changing Parts, and Halion (SE) does react to that, so that part is independant of hardware issues.

While I do beleive you, VST Live is a different application, so we need to figure out what the cause is. Will try to get hold of your devices. You said “MIDI Interface” - which one do you use? I assumed you would only connect USB keyboards so far? Currently I expect some MIDI USB keyboard sending to Halion Sonic SE already gives hanging notes, if there is more in the game, we need to know.
Final question, which computer hardware do you use with MacOS? Thanks for helping!

  1. Switching parts won’t kill the droning notes - it is only silencing them and I’m able to play until it happens again (within few seconds…)
    when switching back to previous part, they are still there and the previous triggered key is pressed (the previous sound is heard and when launching Halion’s virtual keyboard, the droning note is clearly seen).

2.I’m using only USB keyboards - M-Audio oxygen 49 and Yamaha np-v80 (with updated driver).

  1. macOS 15.0 Monterey .

Thank you for your help.

an update -
I recalled I have my small Nectar SE-25 USB keyboard.
it works fine!!! - played for several minutes and it performed as expected! I hope this info would help to understand where the problem might be.

Most definately, thank you so much!
I have 5 different USB keyboards all of which work without those issues. So it must be related to your keyboard(s). You said Yamaha - which one? And you mentioned another one, so pls. let us know with which keyboards the problem occurs, and we’ll figure it out. Thanks again, this needs to work of course.

Sorry, you already mentioned your keyboards, will check.

Found a Yamaha MX series (61) keyboard, no problems either.
If you are willing to follow up on this (sorry for bothering) you might try Devices/MIDI Monitor. Set to your keyboard input and check if a note off is beeing received when notes get stuck.
If the MIDI Monitor shows “Midi Clock” all the time, you will have to disable “MIDI Clock Out” on your keyboard (will add a switch for that).
What concerns me though is that you say the droning notes re-appear when you switch back to the prior Part. That’s totally weird. Otoh, if VST Live considers notes still pressed, it will not disable that Part at all, then indeed only Panic will silence it.
So, it looks like your keyboard does something that VST Live doesn’t understand and MIDI Monitor would really help. Sorry to bother you that much, but 6 of my USB keyboards work (on Windows, that is) and running out of ideas. Also we’re certain that more users would have complained if it was a common problem. Maybe you have something else installed like virtual MIDI cables or some the like? Make sure no other application is running?
Once again, thanks for your help!

The MIDI monitor shows that some of the keys stays in “on” position after released.
and sometimes the screen fills up with “MIDI clock” message as you mentioned.
No virtual cables and no other apps are running.

If note off is missing than we can’t do anything about it…understood that it appears to work with other audio software, but there must be something very unique happening. Suggestion is to check that nothing else is running or in the background etc. Will check with OSX.

That’s nderstood.
Thank you for your attentionand help musicmullum.