Keyboard Controller Basic Mapping Volume Slider

Hi, I’m not overly familiar with setting up midi controller mapping. Just got a brand new M-Audio Keystation 88, which connected to C10 Pro with no set up needed, however, the Volume slider is unmapped. I had a go and thought it was OK, but when I used my sustain pedal, it muted everything. I reset all the Generc Remote input settings and am back at square 1, with a keyboard that works, a sustain pedal that works, but no volume slider. I decided to RTFM, but the information in it was slim and no expanded explanations - almost as if it assumed I knew what the hell it meant. I don’t. I’m happy to read something if I can find it, and yes, I appreciate that I have a steep learning curve when it comes to midi functionality and assigments, but where to begin! The Midi input table is also confusing me. I know I can change the names, but I don’t understand what midi channel it should be or what the address column referes to. I get the Max value column and the Flags column. I tried the following from the Manual

"Assigning MIDI Messages in Learn Mode

You can assign MIDI messages in Learn mode.
Procedure

Select Studio > Studio Setup.
In the Devices list, select Generic Remote.
Activate Learn.
Select the control in the upper table, and move the corresponding control on your MIDI device.

Result

The values for MIDI Status, MIDI Channel, and Address are automatically set to those of the moved control."

The last statement bothers me; I followed this and nothing happened. Is the address supposed to stay at 7? There are a further 15 addresses that are also at 7

Help, point me in right direction. Point me at a good midi guide

Hi,

First of all, you have to set the MIDI Input Port of the generic Remote. So make sure, M-Audio MIDI (or something like this) is set. Then enable Learn check-box. Then move the slider on your hardware. The MIDI address should be assigned (to the line you have selected, of course it’s good to start from the very 1st line - Fader 1). I would expect M-Audio is sending MIDI CC7 at Channel 1. Disable Learn.

Then choose the very same line at the bottom (Fader 1) and assign the function. What do you want to control?

Hi Martin, Thank you, I’ll try what you suggest

OK, this is what I did. You may have to correct any errors. :smiley:

  1. In the Generic Remote page, from the midi input dropdown, I selected Keystation 88 [the options are Not Connected/All Midi Inputs/Keystation 88 MIDIIN2 (Keystation88)]
  2. Ticked the ‘Learn’ checkbox
  3. with the 1st line (Fader 1) highlighted, I then moved the volume slider
  4. Unselected ‘Learn’

Nothing - no change

Earlier, I had , somehow managed to assign this slider, but afterward discovered I had also, by random error, selected the sustain pedal to mute the track and the stereo out - please don’t ask, I don’t know how. So, I know the assignment worked, but now I’m getting no change. keyboard still plays fine and sustain pedal operates fine, also. I keep expecting there to be something to ‘Apply’, to, but that button stays resolutely grey

Hi,

What address is displayed in the 1st line now? You can also change it to any random value and then you can try the Learn again. Is it overwritten after? Or you can just type the expected address, what is MICI CC7 at Channel 1.

Thanks for your answer Martin. I’ve been having this same problem. The critical link that no one describes properly is the relationship between the upper table and the lower table on the Remote Device Setup dialog. If there’s a place where Cubase help describes this process, I couldn’t find it.
Once I got that figured out, the automation worked fine.

Hi,

In the upper part you set the controlling MIDI data, in the lower part you set the controlled parameter/function.