Keyboard shortcut for select all lyrics suddenly disappeared

About a week ago, the keyboard shortcut I normally use for selecting lyrics suddenly swapped itself out for “EventEdit.Nudge.” I can’t figure out how to change it back. (Most other keyboard shortcuts I’m likely to remember are already taken in similar ways to “EventEdit.Nudge.” Yes, I searched this on the steinberg forums. Yes, I found a discussion about editing the .json file. When I open it, there is no such thing as “EventEdit.Nudge.” And the shortcut I want is supposedly assigned to the correct ctrl+alt+L. See the attached image.

Could you maybe upload the json? I’m not sure if the project would help or not but I doubt it.

This forum won’t let me upload a .json file. But I did get the screenshot to upload.

Zip it. It will accept .zip

Here’s a Zip version of my .json file. (1.2 KB)

Make sure you’re in Write mode when you’re trying to use your shortcut, David.

I’m 100% sure I was in write mode when I tried to use my shortcut to select all lyrics. I tried everything I could think of to reset it before posting on the forum. This morning, I was going to make a screen capture video to show you. Just as suddenly as the shortcut quit working, it started working again.
I’ll repost on this thread if the trouble returns.
Thanks for your kind attention!
Bewilderingly yours,

This naturally leads to a question of mine that I’ve had for a while: would you mind briefly explaining what is the reasoning behind certain commands not being available in engrave mode?

‘Filter all lyrics’ is a perfect example of one that would actually come in handy in engrave mode. Sometimes I marquee select a whole column of lyrics and want to nudge them slightly (relative to the column of notes) when engraving a hymn, but to do this I have to switch back to write mode which is a bit frustrating. It’s either that, or I have to shift-click them all.

I do know that in a few choice examples, the key commands are shared and mode dependent, but there are a few commands that I have always wondered why we cannot access them (or at least jump-bar them).

1 Like

The reason that filtering isn’t available in Engrave mode is because of the different way selection works in Write and Engrave modes. We had good reasons for making selections work differently between the two modes, but in future we would like to bring them closer together, and if we’re able to do that successfully, we should be able to make filtering available in Engrave mode too.


Thanks, Daniel. I agree that this feature would be useful.