keylab 49 essential and midi information going wrong

Hi guys,

I replaced my old keyboard with a new keylab 49 essenstial… what I thought was easy seems to give me grey hair :slight_smile:

I will try give in detail information, otherwise impossible to understand what is happening.

first thing : I setup the keyboard with a user1 map where all buttons and sliders are set to MIDI2, then every button and slider has been assigned to a CC (like from CC20 to 31). then send this to the keyboard and this works perfectly… but hold on :wink:

so what I do is this (cubase 10 pro by the way ): I record a midi track with the vst = Analog lab 4.
works perfectly, and then I add some automation on that track up to 5 different ones.
to hear or to see the actual knobs turning and moving around on analog lab 4 vst, I must stop cubase. go to the beginning and then hit play, then all works fine… for the moment.

then I add a second track on midi channel 2, and add for example vst = Engine 2.
then I change my keyboard to usermap USER1 (remember where all is set to MIDI2 and from CC20 to CC31).

when I records a midi part that I play on the keyboard, excellent, there it is.
but then… here it comes now…
I assign in the VST instrument some buttons to the knobs on the keyboard. SImple I do learn and move the knob on the keyboard.
for example the knob on the keyboard CUTOFF = CC20, RESONANCE on the keyboard = CC21.
when I move those knobs while the song is playing, I can see the knobs on the VST moving… great ! but hold on… not there yet.

remember I had also automation on the midi channel 1 of analog lab… the moment I activate the read automation on that midi1 track, I can see that analog lab 4 knobs on the vst are reacting perfectly… but… here we are now :slight_smile:

when I leave the read activated on the MIDI1 channel of analog lab vst, and then select my track midi2 with Engine on it… and then while the song is playing, then big big problems… the moment I start turning on the knobs of the keyboard, I can see the vst knobs reacting, but it’s like something is sending info to them also… since when I try to move the knob on the keyboard that is linked to CC20 and is linked to cutoff of the engine VST, then I can see that when moving the knob to 127, all of the sudden the vst knobs go down to 60 or 45, without any recorded automation on that track. the moment I deactivated the read automation on the first track, MIDI1 = analog lab, and go back to the MIDI2 part Eninge, and then I start to move the knobs, again, then the vst knobs of engine do react as should.

so that’s my first problem I encounter and banged my head against the wall for 2 days… nothing to find online… any ideas?

also what I very strange is that it seems that I can not record the automation on seperated tracks.
when I activate the read and write on the midi2 channel and start to moving the knobs on the keyboard, then I can see the knobs moving on my vst, but no automation is recorded. when I move the sliders in quick controls, then it does react and write…
in cubase I added a new remote device where I set all paramaters on top to midi 2 and then from address 20 to 31, like my user map1 on the keyboard.
but still when trying to record my automation data while moving the knobs on the keyboard, I see the knobs on the vst moving, but in quick controls they do not respond and then ofcourse the automation data is not recorded…any idea how to make this work again?

I think anybody that can give me some tips on my problem 1 and problem 2.



MIDI CCs 16-23 (so your MIDI CC20 and CC21 are included) are assigned to the Track Quick Controls by default in Cubase. Maybe this causes both issues?

Double check Studio > Studio Setup > Remote Devices > Track Quick Controls, please. Make sure MIDI Input is set to Not Connected here, please.

HI Martin,
mean time I found out that the latest firmware 1.1.6 is causing this bug. when going back to 1.1.5, this problem is solved.
and ofcourse I had other midi CC mapping in my quick controls :wink:

the way I installed it and work with it was 100% correct, only the lates software cause midi data to go back to keyboard and then started to mess up other stuff.

Hi deech123,
thank you so much ! your info is super useful ! I solved same problem :slight_smile: