Kirnu Cream midi output does not play in sync

Hi all,
I’ve been trying out Kirnu Cream (free VST from latest Computer Music edition) but have had no luck in getting its midi output to play another VST in sync.

I created a new VST instrument track with Cream, put a few chords on it and then routed it’s midi output to the midi input of another VST synth. The arps play but not in sync. What’s interesting is if I record the midi output on the other VST track I can see the arp notes with perfect timing and I can play back that recording in perfect timing.

Any ideas?

Many thanks!

Hi I’ve recently bought kirnu cream also, downloaded it to my usual vst folder but could Cubase on recognised the 32bit version and I couldn’t route any synths to the plug in??
I have Cubase 7.5 64 bit windows 7.
Did you resolve your problem?

I’m using Cream with C7.5 and win7 64bits. I only use 64bit plugins so I think cream is 64bits, don’t remember noticing.

Anyway I had it when I installed cubase and haven’t noticed any problems with it.

I have some sync problems with I record the arps from my mox6, just a little lag and requires quantizing.

Are you using whole note chords to trigger cream?

No never solved this. Contacted Kirnu and they said they would look into it but never got back to me. Gave up :frowning:

So it works on the other vst track?

Just use that?

Have you tried it on different plugins?

Is there just one that it doesn’t work on?

If an instrument has a lot of latency it would cause sync problems.

Try recording it on the target track and look at what you’re getting, is it just a little lagging or what?

Can you just quantize the recording?

The same problem occurs with different instruments and I’m not aware of these being CPU heavy.

If I record the virtual instrument (with Kirnu midi output routed to the input of that instrument) then the notes are in sync (and no, the auto quantize is not turned on).

So I have a workaround - just record the VSTs midi data. It would be nice to have this work in real time though and understand why it’s broken for me.

Thanks all.

I found the solution.

I reduced the latency on my sound card. The ASIO buffer size was set to 2048 samples. Reduced this to 512 and it works fine.

However I remember now why I had it set so high. For some reason after installing Windows 8 I started getting audio clicks at lower latencies where before in Windows 7 it had been fine - most noticeably when mouse movement occurred. Not been able to solve this after trying many things. I’m using an old M-Audio Delta 410 which only has Windows 7 drivers. Any ideas would be much appreciated.


Sorted. I updated my graphics drivers and all is good again.