Kontakt, NotePerformer or other VST2.x plug-ins being blacklisted?

In the meantime, I could help users tracyross, Fitsch and udr by providing them a new plug-in-manager component.
Now, I’d like to get a little more safe and make sure that my fix works also on other machines.

Therefore, is there anyone else still having trouble getting NotePerformer, Kontakt or other VST2 plug-in getting listed in Dorico?
Then please send a mail to ‘u dot stoermer at steinberg dot de’ with a short description of what your problem is.
If it is really that very same issue, then I can provide the new component plus instructions to you.
Thanks for attention.

Hi Ulf,

Here are the blocked vst2’s in Dorico (latest version):
-Labs (64 Bit)
-Modular V3

I still get a crash (A serious error etc.) with a scpecific file but very strange:the crashdump file is zero bytes…youallready looked into this but to no avail; Spitfire cannot find it either.
should I delete the VSTAudioEngine folder? Or make a new file and copy the notes into that file?


FWIW, since the last Native Instrument updates, other NI VST2 plugins such as Kontakt and Reaktor are getting blacklisted in Cubase 10 too.

But Cubase has a mechanism to “reactivate” blacklisted plug-ins. Have you tried that?

Yes, and the plugins work, but it would appear that NI introduced something in the most recent updates that causes them to be blacklisted. I’ve asked on the NI forum too but there doesn’t seem to be much interest in addressing the problem. As usual, everyone seems to be pointing the finger at everyone else.

That could well be an issue on our side. And could actually be the same as the one in Dorico. Do you want to help trying to find out? I could send you the same component and instructions for Cubase.

Yes, I’d be happy to help! Please PM me (I’ll get back to you as soon as I can).

MrSoundman just confirmed that my fix in the vstpluginmanager also worked for him on Cubase. Big thank you for having tried it out.

Hi, I’m relatively new to Cubase & have the same problem with NI Massive, Reaktor 6 & Reackor 6 FX being added to the blocklist.

NB: I tried reactivating like mentioned above but Cubase 10.5.20 displays a message (Liecence, retry, Cancel) when I tried to use them & locks up. I had to reboot the PC.

Can you advise the solution so a newbie like me can understand, thanks.

Hi GunnPoint, your case looks different. Do you really have a valid license for Reaktor and the others? Because it seems they get blacklisted because there is no valid license for them around.
Also, would you please go to C:\Users<yourname>\AppData\Roaming\Steinberg\Cubase 10.5_64 and zip up the two files
Vst2xPlugin Blacklist Cubase.xml and Vst2xPlugin Infos Cubase.xml
and post them here. Thanks

Hi, I’ve been having a problem with Massive X being blacklisted in Cubase 10.5 on Windows 10. I have a valid Komplete license, but reactivating Massive X crashed my PC. I raised a support request in July 30 but have had no reply - is there a fix for this please? NI support have been very helpful but, as Massive X works fine in the Komplete Kontrol app and in in Reaper, they thought it must be a Cubase problem.

Hi ChrisW,
would you also please go to /Users//Library/Preferences/Cubase 10.5 (just out of my head, might be slightly wrong)
and zip up the two files
Vst2xPlugin Blacklist Cubase.xml and Vst2xPlugin Infos Cubase.xml
and post them here.
Depending how they look like, I might be able to help.

Hi Ulf,
Thanks for offering to help, the two files are in attached file
Vst2xPlugin Infos Cubase.zip (2.31 KB)

Thanks for the data, Chris, but I need to find out something more. Please do the following

  • Press the Windows key and then type the letters C, M and D and then the enter key. A little black Command Prompt window shall appear
  • Copy and paste into that window following command: “C:\Program Files\Steinberg\Cubase10.5\Components\vst2xscanner” -p “C:\Program Files\Native Instruments\VSTPlugins 64 bit\Massive X.dll”
  • Press the enter key

What happens then? After a few seconds normally an XML document shall get written to the window. If so, please copy the output and post here.
If nothing gets put out, type the command: echo %ERRORLEVEL%
After hitting enter again a number shall get displayed. Which one is it?
Many thanks

Thanks Ulf,
I ran the command in the Command Prompt window, but got the error “The system cannot find the path specified”. I couldn’t spot anything wrong but attach screenshots of the Command Prompt and two folder windows.

Sorry, just noticed I need to update my signature! I’m on Windows 10 now.

Sorry Chris, here the corrected one:

“C:\Program Files\Steinberg\Cubase 10.5\Components\vst2xscanner.exe” -p “C:\Program Files\Native Instruments\VSTPlugins 64 bit\Massive X.dll”

Thanks Ulf, this is the output:-

cannot resolve resource: application_ENG

<?xml version="1.0" encoding="UTF-8"?>

C:\Program Files\Native Instruments\VSTPlugins 64 bit\Massive X.dllInstrument5653544E6924486D61737369766520785653454E6924486D6173736976652078Massive XNative Instruments GmbHVST

Hm, that’s the expected and valid output. So indeed, you are a candidate for my fix. Please send a mail to ‘u dot stoermer at steinberg dot de’ and I’ll send you some instructions.

Thanks Ulf, your fix worked for Cubase 10.5.

Excellent news :smiley: