Kontakt Plugins think they are not authorized

Hi, hope some experts can help. I installed Cubase 8 yesterday, and things seemed to be working fine, but today, my Kontakt 8 plugins are all appearing as demo versions. The warning I get tells me to go to Service Center to activate the plugins, but of course, they are all already activated from NI’s point of view, sitting in the VSTPlugins library under Cubase 6 (64-bit). I should note that during the Cubase 8 installation, I did get the error message “This software requires installation of device driver TPkd and a reboot before running. Please reboot or reinstall the software.”

It was odd that they all seemed to work at first. Maybe I was hallucinating.

I checked the settings under Plugin Manager to ensure that my Cubase 6 plugin library was included in the path (it was). I rescanned the libraries, and I got the same TPkd error again.

What should I do?

BTW, the project I tried under Cubase 8 also does not work under Cubase 6 any more because Cubase or NI or whatever thinks the Kontakt plugins are demo, and timed out. So I can’t work on this project any more. This would apply to Guitar Rig 5, as well as Scarbee bass, Mark I electric piano, and Absynth.

Before I go find a TPkd drive and rescan my libraries for plugins, has anybody been through this already?

Thanks in advance.

I had this in Cubase 7 once and only once.

I just re-authorized them - [K 4 and 5].

It’s been fine since then.

Can’t quite remember if I had to uninstall and reinstall them to get past the Service Center, but that’s not really a big deal - just do a thorough clean up before reinstalling.

Use Ccleaner or something similar.

Hey, thanks, Jamusic, I did click on the link to authorization, but all were currently authorized, so no action was taken. Still, they appear as demos (and expired) in Cubase 8. Meanwhile, they are working in Cubase 6 as long as I didn’t use the project in Cubase 8.

Other ideas? Thanks again, Jamusic.

Hmmm…that’s odd.

Only other thing I can suggest - try closing Cubase and shutting down the computer vs. restarting it.

Wait a few moments, then start the computer again, and try Cubase again.

Watch the start splash screen - hopefully it will rescan all your plugs.

This has happened to me several times (although not specifically with Kontact) after upgrading Cubase. For me it was caused by something changing the “Run this Program as Administrator” program rights. What I had to do is to go into CB and all of my plugins that were messed up and clicking on the checkbox to run as admin again. Had to do this in the plugin stand alone and VST versions.

Hope this helps. :wink:

Regards :sunglasses:

Hi there

I have this happen every so often, NO idea why, don’t think it’s anything to do with Cubase. I just load the service centre and reauthorize, never had any issues with that.

Best Regards


Thanks, Prock. I’m not sure I understood what you’re suggesting. I did go to the properties menu (right click on the cubase 8 exe) and found the place to click on “Run this Program as Administrator”. This is not set for Cubase 6, btw.

When I look at the properties for DLL, I can’t find any place to click on “Run this Program as Administrator”.

Anyway, making this change doesn’t solve the problem.

Thanks, Dave. When I go to Service Center, it says all my software is authorized. I don’t see any option to “reauthorize” in there. Maybe I’m missing it?

Thanks again, Jamusic. I did shut down and restart, nothing seems to help. Maybe I should uninstall and reinstall Kontakt 8 as you suggested earlier. I think that will take a long time…

Looks like I got some terminology about the plug-ins messed up a bit. So let me correct that and give you the full steps I had to take to get my NI vsts (not Kontakt though) up and running.

  1. You said you did this step but maybe you did not do the whole thing, right click the CB .exe file and go into properties > compatibility > change settings for all users > and click the “run this program as an administrator” box under the privileges area. It is the step to go into the “Change setting for all users” is what is sometimes missed.

  2. Do the above procedure for each stand alone .exe file you are having trouble with.

Hopefully, at this point, your stuff will be working again but if still having trouble do step 3.

  1. For the stand alone plug-ins right click the .dll file and make sure the permissions under the security tab are set to “allow” for the “system”

Hope this helps but… it may not be it for your situation. Again, this has happened several times to me after doing a CB upgrade. Weird wild stuff :wink:

Regards :sunglasses:

Happened here once or twice after upgrade. There’s no button to re-authorise in the service centre, it’s just a matter of re-typing the serial number in the service centre on affected plugs, quick enough to do and you shouldn’t have any problems after that.

Thank you, Outsounder, I did try re-typing the serial number, and it did not solve the problem.

I am beginning to wonder whether the fact that I turned Hyperthreading on has anything to do with this. It all seemed to happen after that. I had turned off hyperthreading based on the earlier recommendation from Steinberg, but then turned it back on with Cubase 8, as it doesn’t seem to help to have it off any more (or at least I wanted to find out).

Maybe turning on Hyperthreading creates an update to the machine ID that NI uses, because of adding four virtual processors? What made me think this was that the message in Absynth was a little different - it said I had new hardware which is why Absynth thought it wasn’t activated.

To Prock, I did try the steps as you suggested, but they did not solve the problem.

Thanks again, everyone.

Funnily enough this just happened to me yesterday, not with Kontakt but with ProQ2. The only thing I’d done prior to it happening was run JBridge set-up and VST scan.

I did try re-typing the serial number, and it did not solve the problem.

There are three fields in the service centre

Serial number, System ID and Activation Key

Delete the activation key and re-enter the serial number then activate. The activation key is part of the challenge/response so will be re-written.

Sometimes, updating the Steinberg Dongle with new drivers and updates can be seen as a hardware change by some software, Ueberschall and Toontracks quite often behave in similar way, especially if you use a USB dongle to connect to Internet. It can be seen as a change to hardware setup if it’s physically removed before disconnecting from Internet in control panel first, forcing a re-activation.

Thanks, Outsounder. Unfortunately, I already started a complete re-install, so too bad I missed this shortcut! I’ll write it down in case it happens again. I hope the re-installation completely solves it, and it’s a good thing I found the disks.

Problem solved by complete re-install. Thanks to all for the help.