Korg Midi Controllers not Detected in Dorico 4.2 with WinRT

My NanoKontrol 1 and Nanopad 1 controllers were not detected in the Preferences–>Play–>Midi Input 4.2 (Win10 with latest Korg drivers installed).

Disabling “Enabling WinRT Midi” in the Preferences–>Play–>Advanced did the trick however only after a full system reboot. Just restarting Dorico didn’t take.

I’ve noted the WinRT option seems to be a common issue with some other 4.2 midi input problems so if you try toggling it for debug, make sure to try a full system reboot.

1 Like

Welcome to the forum, Daniel, and thanks for taking the time to share this experience. It really shouldn’t be necessary to reboot your system completely after turning off that option, but perhaps the audio engine didn’t exit cleanly when you quit Dorico?

Your quite right. I don’t think the reboot was necessary in my case. I’ve found that if I toggle the setting in the Hub the change is immediate after I close the Hub and reload. If I change the setting with a project window open the change isn’t applied when the Hub comes back up.

My misunderstanding is that I was equating closing the project with closing Dorico. I see that it’s the Hub that needs to be closed to properly quit Dorico.

Thanks for the feedback and warm welcome!