Korg nanoKONTROL2 & Quick Controls

I set up my new Korg nanoKONTROL2 to remote control as “Mackie Control”, and it works fine.
Now I want to control my HALion 4 Quick Controls with the knobs of the nanoKONTROL2.
Unfortunately, this also moves the Cubase mixer pan control.
Does anyone have any idea how to solve it?

jim99

Hello,

It’s not possible to solve it this way. You can use any device as Mackie controller only or as Generic MIDI controller (and use the QC) only. It’s not possible to combine it. I can imagine this only one way, the controller can transmit MIDI data on different switchable MIDI ports.

Thanks for the feedback. :slight_smile:
I’ve checked to solve it in an other way:

  • If I want to use Quick-Controlls, I active the nanoKontrol2 in CC-Mode
    if I want to use a mixing-scene, I switch to Cubase/Mackie-Mode

Not perfect, but it works!

Hi there,
jim99, can you write how you’re solving this problem? I’m asking cause when I’m in CC mode Quick Controls are working as you said, but the problem is it’s mesing with my midi fader at the same time.

I found this thread while solving the same issue and wanted to add a further notice that should also solve Dlk’s problem.

I found that, while trying to setup it, I had set up the “Quick VST control” setting. So, in order to have all controls in place and only active for VSTs:

  • plug NanoKontrol2 USB while holding buttons “cycle” and “set”
  • open Cubase
  • go to “Devices --> Device Setup”
  • find “VST Quick controls” and “Track Quick controls” and set their MIDI Inputs and Outputs to “Not Connected”.

This should leave all knobs and faders free to use with VSTs. I imagine that, while mixing, the Quick Controls may be enabled again just for that time.