Lag when deselecting event - shown by video

Deselecting events has lag when clicking free space within loop region but not when clicking outside of loop region.

https://youtu.be/3xD457FwzF8

Hadn’t noticed as it’s not as marked as on your set up, but I’m getting a very slight delay when pressing open space within the loop too.

It seems to be a little intermittent, if I keep pressing between the event and the space sometimes I get the delay and sometimes I don’t.

I tested this with a bigger project than the one shown in the video. There’s a small delay (that seems to vary depending on the project size) when deselecting events between locators here, but it’s nowhere as bad as this.

Just tried it on my Windows 8.1 set up and the lag is still there but not as bad as on the Mac Sierra side.

This is only a Cubase issue, but I have a temporary solution.
Go into System Preferences on your mac, click on Mouse and raise the Double Click Speed to a higher value.
Mouse-Double_Click_Speed.png
Cubase somehow is affected by this, especially if you are using a wheel mouse.

I admit I doubted …but you’re correct Evertone
I changed my double-click speed for my mouse to the fastest setting and indeed deselecting audio or midi events and opening plugins operates faster. Which is odd because we are only using a single click for both operation.

CB is affected in a weird way by this mouse setting. If you lower the Double Click speed all the way down, the lag gets extremely worse.
The good thing is that at least the issue vanishes completely by adjusting the speed.

I do have to admit though, that outside of Cubase I feel like the fastest finger gunslinger in town.

Same here on Windows 10. The lag when clicking to open plugins was discussed previously, but I don’t recall this other thing being a part of that. I never noticed since I always have my double-click speed set to the fastest, being the fastest gunslinger in a radius of 5 meters of myself. :stuck_out_tongue:

Here’s a simple repro sequence, Mac and Windows.

In the OS, set mouse dbl-click speed to the slowest setting.

Then:
New project, with two midi tracks
Add a part on one of the tracks
Set the locators so the event is inside the cycle
Select the part
Still in the cycle, click in an empty area of either midi track.
Result: a delay before the selected object becomes de-selected.

Now set mouse dbl-click speed to the fastest setting and do it again. Observe difference.

Incidentally, the repro won’t work if you click in an area where there is no track, nor on FX, Group, Automation Tracks, and I would guess but didn’t test, Rack instrument audio returns.

edit: not a bug. :confused: :open_mouth:

I think I now understand the logic of the delay while deselecting an event or a selection of events.

Because there is a feature to double click an empty area to create a new empty event ( which is the length of the loop region) Cubase waits for the second click to do anything else. Hence adjusting our double click speed either increases or reduces the wait time to deselect events.
So I’m going to look for a key command to deselect events and use that instead of clicking on empty space. :slight_smile:

Regarding the opening plugin delay I’ll put in a feature request for Steinberg to remove the " double click to open plugin" command so our “single click to open plugin” will function more efficiently. As it stands it’s counter productive for Cubase to be waiting for a second click to open the plugin when we could all save a click and open the plugin with one click. :slight_smile:

James, I totally missed that. Nice one.

Haha!

Thanks Steve for the detailed step by step repro.
Whether it’s a bug or not, I think James is on point on that the double-click an empty area is what’s causing this. Maybe SB can make this a simple On/Off preference, that way those of us who don’t use this feature can turn it off and have a normal working mouse when not using CB.

There is a “Select None” key command that would work out for you.

Great idea! You have my +1 on this one.

I would bet that this wouldn’t be changed, since it’s specific to double clicking in the cycle area, and then, only on a track type that can have objects added to it via a double-click.

Yeah, you’re right and it makes sense why there might not be a change. The good thing is that one can get used to having the speed all the way up and work normal within CB.

Yeah, or use a mouse with a bunch of buttons. On my kensington trackball there are four, one is set to double click, one to right-click, one to ctrl-click and one to plain old click.

Thanks evertone I now have select none assigned to a key command and it’s working well. :slight_smile:

Steve,
I also have a Kensington Trackball mouse and it’s nice having those extra buttons. Good idea!

James K,
Enjoy!

I have a Logitech tracker ball mouse and I’ll see if I can set one of the other small buttons to double click. That would be fantastic! Great tip!