Last Bar of Local Frame Not Visible

Using a custom master page I have a local music frame at the bottom of a page:
and it shows 7 of the 8 bars in the flow.

How can I get it to show all 8 bars in the local frame?


In Engrave mode, with the Frames editing toggle switched off, select the first note in the first bar of the local frame.
Add a frame break (from the left panel or using Shift-F).
Select the purple frame break flag.
In the bottom panel you’ll find the “wait for next” property - tell it to wait for the next frame break.

If there’s only one frame break at the start of the flow, doing this gives Dorico no choice - it MUST fit all the music in the one frame.

Thank you!! That did it!