Latency Again

I’ve gone back to Windows 10 for my Cubase 12 pro.
I’ve now got different symptoms now hopefully i’ve uploaded a screen snap.

Any help please. Im not sure if its windows or the bios,

What’s the actual issue?
DPC latency check is green and saying your system is suitable for real-time audio.

If you’re having issue unrelated to this screenshot then you need to run the monitor for a LOT longer than 45 seconds. If I test, I let it run for at least 15-20 mins and while I’m using the DAW too - you don’t want to let it sit idle for a short period with nothing running.

OK Thanks.
Latency spikes and high latency reading my Native Instruments KA6 interface monitor.
It used to be 6in and 8 out for the latency readings but is hopping around all over the place now.
I did try Windows 11 and thats when the problems started. Im not sure now if this is a window issue or a bios issue.

DPC Latency won’t make those figures hop around to my knowledge - it would just cause glitches when trying to operate at lower buffer sizes. But the reported latency should remain the same as it’s from the driver and deliberately designed to stay as stable as possible.

It sounds like your audio interface isn’t reporting the correct latency or keeps sending new values for some reason. Could it be that the sample rate is changing? I had a broken audio interface that couldn’t lock on to the sample rate and would jump around - but you could hear the pop on the speakers as it jumped.

Have you tried updated the drivers for your interface? Latest version appears to be Sept 2021.

One other thing, where are you reading this latency reading, is it from Cubase or a Native Instruments application?

Its from the Native Instruments. i have installed anything only the interface software which is the latest for the KA6.
When i ran Cubase 12 originally the project i tried crashed and then thats when i noticed the latency spikes

Ah ok, I don’t use NI interfaces so can’t really help. But as this is an NI issue with Windows you may get better support on their forums perhaps? Just thinking, if you don’t get help here. :frowning:

Thanks, I was hoping it maybe a common problem.
Ill check the other forums.
Thanks for your input.