Latency Compensation

I’m trying to understand the latency compensation thing.

My DI on 128 samples is giving the following details:
Input L: 238 samples (5.40 ms)
Output L: 198 samples (4.49 ms)

So it was my understanding that in the relevant Cubase track i’ll need to set the compensation to -449 ms.
But actually when setting to -220 I’m on beat.

What am I missing here?

What are you trying to do? You talk about two things that aren’t related in any way.

The DI output latency is the delay from when the sound (final mix) leaves Cubase and when the sound leaves the DI (i.e. the delay from Cubase to the speakers). The track setting is to adjust one track’s timing against other tracks within Cubase and is in no way related to output latency.

And if the output latency is 4.49 ms why did you think that a track setting of -449 ms (a hundred times longer) would be a good setting?
And what problem is the -220 ms track delay the solution to?

Ok - seems like you’re correcting me on several things and these pointers are the cause of my misunderstanding…
So - thanks for replying, and I’ll explain to hopefully understand better:

I’m using Digitakt to play the drum part via midi, and all other parts are audio.
I program the midi (on Cubase) and playing back, the latency makes the beat come in late.
So I figured - ok, let’s see what the latency is, and came across “latency compensation” which seemed to be explained as the solution.
It seems I’m mixing things up in a major way and would appreciate you making sense for me…

(As for the 4.49 vs 449, it was my understanding that the DI and Cubase actually read the same… but again, I’m messing things up)

I’m sorry if I sounded rude in any way, it was not my intention.

Ok, so DI was an external drum machine, I thought it was you sound card. Sorry. :blush:

When you say “the latency makes the beat come in late”, is that a fact or a theory? If you e.g. load a drum VST in Cubase and test to use that instead - is everything on the beat then?

  • If it is not, then your problem isn’t about latency but about tracks not being in sync (and the problem is more likely that it is the audio tracks that is not on the beat…).
  • If an internal drum machine is on the beat then you’re correct about the problem being a latency problem. The audio from Cubase has a latency of 4.49 ms while the midi is sent without latency. If your Digitakt in itself has a latency of 0 ms then everything should be on the beat if you set 4.49ms (not -4.49ms) in the track delay for the drum midi track. (i.e. you delay the midi signal with the same amount as the audio is delayed by the latency)

If setting a negative track delay solves your problem it only makes sense if the Digitakt has an internal latency of about 225 ms, but that sounds very much for a drum machine…

How is audio routed after the Digitakt, could there be any latency in that part of the chain? (i.e. how/where is the audio from Cubase and the audio from Digitakt merged and mixed?)

Hey - all is good, and you weren’t rude but helpful.
And actually you were right - DI - I meant my sound card…

So again, to clear all up:
I’m using Digitakt as am external drum machine, routed direct into cubase via Overbridge.
the physical connection is USB.
When on the Digitakt midi channel I place a note on the top of the bar and play it back - it’s late.
Only thing that solved this is the setting of negative delay -220…

(As for your question: I opened up a Battery instance, and there’s a big delay from the second I hit my external keyboard to the actual sound)

I hope I managed to convey the setup, and again thanks

I’m not familiar with the Digitakt/Overbridge products, but it seems as if you have some kind of generic latency problem in your setup. With a Battery VST you should expect a 4.49 ms latency between key press and the actual sound, and latency below 10ms is normally considered to be not noticeable. If there is a “big delay” there is something else in your system that is causing the latency.

Got you.
I’ll try to figure this out.