latency/ drift with long recordings

Hey there,

Setup: iPad2 32GB w/ 4GB available space - Recording 4 tracks 24bit@44kHz simultaneously (2 mic + 2line through Komplete Audio Interface)

After importing the project to Cubase 7.5, I experience what I’ve heard somewhere before:
After some time recording, the two line tracks (which come from an identical source) have a drift/latency between them.
With track delay (setting in the Cubase Track inspector) I gauge that the drift is about 46ms.

It seems that the drift is not scaling up right from the beginning. Up to the ~10min mark everything is in sync - then it “happens”.
It seems to stay at ~46ms. (the whole recording was 16min long - I might try at a longer one, since I am up for a live recording on Friday)

[I suspect that it’s a matter of the limited RAM and slightly “out of date” CPU of the iPad2…]

=> Is there any speculation or experience about this not happening with a newer iPad ?

greetings
Frank

Hi Frank,

Thanks for the info,
I make some tests and inform you about the results.

best
jan

Hi all,

This latency drift with long recordings wasn’t reproducible ervery time, but i had an repro here.

I am happy to can say,
This issue will be fixed within the next release version.


best jan

Sounds good. Meanwhile I had my first field recording: worked well in case of latency - but the iPad bailed on me during the first set. Growing pains (?)
:wink:

I have a MIDI track that I am feeding into iFretless Bass via AudioBus, and I am encountering what appears to be some latency in the recorded track. Playback of the MIDI track through iFretless bass is spot on, it’s just that if I record the output from AudioBus, the recorded track is off. It isn’t consistent throughout the track either. Sometimes everything looks ok early in the track, then things are off near the end.

Does this sound like the same issue?

Here is a look at the MIDI vs. the recorded waveform to illustrate it:

IMG_0001.PNG
Hi leedgitar,

My testcase,

1.launch audiobus and assign iFretless Bass as input and cubasis as output
2. go to cubasis, create midi track and assign iFretlessbass as midi output
3. create midi event and draw some midi note
4. activate audio track record enabled and start recording

Result : audio file started at the same time as the midi note, no latency
Note : see attached picture, iOS7.0.4 / Cubasis 1.7.2 next release version

Thanks Hiltmann. My song has 5 audio tracks, not including the MIDI/audio track for the bass there. I’m running on a 1st gen iPad Mini. All other apps are closed and I have > 9GB available in storage. That will be awesome if this is fixed after the 1.7.2 update, so I’m looking forward to it!