Latency headache

Hi I have a latency problem thats driving me nuts! I have a top Pc with i9 processor and 32GB ram. I have set buffer at a very low 64 and both input and output latency is showing a tiny latency of 3 ms. I am using a Focusrite 3rd gen interface. All good gear - right? When I go to record I get a terrible echo which makes it impossible to sing to a track. If I engage delay compensation its possible to record but I always have to move the finished recording along because its late. Ive spoken to Focusrite and my interface is set up properly. Any ideas ? I should be able to record without even using delay compensation shouldnt I?

Where do you set this exactly?

On the toolbar at the top of the project (constrain delay compensation)

In the audio system settings there are Adjust for Record Latency that you can have on/off and also Record Shift that is useful if the shift is constant.

Thanks LarsErik where do I find audio system settings/ Im on Cubase 10 pro

I’m away from my DAW but I think it’s the Studio menu and “Studio Setup” somewhere close to where you select the ASIO drivers and buffer size.

Found this on another forum where someone did a copy/paste from a Cubase manual:

Adjust for Record Latency and Record Shift
You may experience that audio material you record end up in a displaced position, too early or too late. The reason for this happening is often one of the following:

• Your audio hardware reports an incorrect Input latency value in its communication with Cubase.

• Your system has a high Output latency and you’re recording with input monitoring through an effect plug-in, which in itself has an inherent latency.

This means there will be a delay between when you play something and when you actually hear it. In such a situation, you may often instinctively play “ahead of time”, in an attempt to compensate for the perceived delay. However, because Cubase features automatic plug-in compensation, meaning that plug-in delays are compensated for to maintain sync and timing, the audio you record will end up in the wrong position (too early).

You can compensate for the above by adjusting these two parameters.

• By deactivating “Adjust for Record Latency”, you instruct Cubase not to use its plug-in delay compensation feature.

• If you change the Record Shift value, the position of recorded audio will automatically be shifted by the corresponding number of samples (up to 100000).

Positive values shift the position forward, and negative values shift the position backward.

Thanks very much that is very useful. I think I can solve my problem now!

1 Like

I’ve seen this type of thread before about hardware.
You have all the stuff but it doesn’t work well.
which motherboard do you have ?
The motherboard can make all the difference.
When i build a pc now i always use a gaming motherboard.

Hi Adrian cant remember what the MB is but its top notch. Ive decided to record everything with no plugins whatsoever - zero latency. Ive had enough of this problem.

Could you answer my question above?
“If I engage delay compensation…” suggests that you are trying to switch on/off “Constrain Delay Compensation” toggle on the project window.
And if this switch cuts the latency down, then that means you have some plugin that causes delays in the recording chain.
You cannot ‘delay compensate’ buffered plugin while the plugin is in use, that requires a time machine. So you have to avoid using such plugin on recording e.g. in stock cubase plugin set, compressor, expander, multiband comp, multiband envelop shaper, etc, and any EQ/Filter says ‘linear’ also causes delay. If one has ‘LIVE’ switch on plugin gui then that cuts the buffer, but usually, you can’t make them 0 latency, they need to buffer signal for a short moment.

Its an Asus Prime Z490

I decided not to use any plugins at all during recording. Its the only way I can get rid of any latency

You don’t need to turn off all.
You know there are plugin that makes a little audible gap when you turn plugin switch On/Off or on insertion. Those are the ones that has buffer.
If you insert a plugin while playing, and the playback is not disturbed, then that plugin does not buffer. You can use these plugin in the recording chain.

Also if you already have a nice mix balance using lots of plugins in master for example, make a group then route all other tracks to the group and do the master processing there and keep the master clean. And make sure the recording track does not go there, same goes to FX sends, don’t send from the recoding track. This way you can still use plugin on every other channels but still get the lowest possible latency same as on an empty project.

Thats great advice thanks very much. Ill have to start experimenting!