Latency in my headphone

Hello guys,
I just recently upgraded to N12 from 11.
In N11 my headphone mix is perfect. However, in N12, I’m getting some latency. I know it’s not my audio card because it works fine in 11.
Where is the adjustment in N12 to reduce/eliminate this latency? Any help would be greatly

Have you selected your audio card asio driver in the studio setup - Device setup dialog? (Rather than using default).

If so, you can also check your asio guard settings there.

If it is working in N11 try opening N11 and copying the settings from that area, to N12. (Or make a screen shot).


Hi Phil,
I appreciate you replying and suggestions. The culprit was NOT having “DIRECT MONITORING” checked. As soon as I selected “Direct Monitoring” the latency disappeared.
Dumb oversight on my part. But truthfully, in all my past upgrades for Nuendo, this is the first time happening.
Anyway, thanks again for replying.