Latency issue

hi,im using cubase 6 latest version on a pc.
i had ben working on a track with battery 3 lastest version,with no probs.I have battery loaded in vst rack with all outputs selected.Today i loaded the project and i seem too have slight latency issue when playing a sound from battery on my nocturn 25.
i checked rmv and groove agentone,but no latency issues with them.
I have no probs when i open battery as standalone.
i am using Focusrite Saffire pro24

UPDATE!!
tHE GROOVE AGENTONE IS NOW DOING THE SAME THING.i had previously just checked them and unloaded,but now i have used them on a miditrack,and when i play there is slight latency.

this is def a pain.i have just opened new instance of battery 3. no latency a t all so far,although the other instance has slight latency.
There are no effects inserted,its just exactly the same kit with same settings.
Grooveagentone still has latency on one instance,and none on another.
PLEASE HELP.

No latency at all is rather exceptional :wink:
What buffersize are you working on?
Is there any latency when Cubase plays, or only by midi input?
Did you try enabling “constrain delay compensation”, does the latency remain?
Did you try to open a new project with 2x battery to check if the different latency remains?
Do you have System Timesstamp for Midi or Direct Music enabled?

hi,i have had it at 1024 and 512 same results.
When i say no latency i mean,when i hit a key on the midi keyboard i instantly hear the drum sound.
i only gett he latency problem on midi input.
where is"constrain delay compensation " option? and"System Timesstamp for Midi or Direct Music "
i checked on preferences but couldnt see them.
I am goin to try new project and see.

In the event editor on the top left (when enabled by right click on the tools bar of course). It’s a clock surrounded by two brackets.

Optional you can adjust the treshold when the compensation kicks in:
Preferences -> VST -> Delay Compensation Treshold (for Recording). But I would suggest at this stage to keep it a 0,0 to check if it solves something.

Devices -> device setup -> MIDI Port Setup -> tickboxes below

i have just opened a new project with 2 batteries.
No latency.
i havent changed any settings,and itst he same kit.
N.B i was having the problem in Groove agentone also,so its not battery problem.

i am also noticing in the problem project,when i move the cursor,sumtimes i get the little circle spinnin,as if cpu is under pressure.
But,its not a big project by any means.
cpu shuld be fine.

ok,heres what i have done.
i just deleted the problem battery and grooveagentone from the rack,and just added them again.with same kits.
No problem as yet.
strange one,i know.

Did you re-enable Steinberg Audio Power (Devices -> Device Setup -> VST Audio Sytem) after updating Cubase? It defaults to off after the update, even if you had it set on before. This would explain the apparent CPU load being high.

thanks for reply.
yes it is activated.
audio priority is set to normal. is this ok?

I was renaming a track and when i typed a letter,the little circle came up for few seconds.
Has to be a reason why this is happening.

Well, mine is but I’m not sure how much of a guide that is as I’ve never fiddled with it. I also use Multiprocessing, which I know was a point of debate some time ago.

Maybe you just had a dodgy project. Thankfully rare but I have had them.

'Fraid that’s all I can think of right now. Good luck, C

Autosave?

yes autosave is set to 1min.but it has been for ages,and i dint have the circle.