Latency issues and crackling introduced in 3.3

I used Cubasis as realtime effect host (with all that beautiful Waves plugins) in combination with loopy HD (fed audio in RME Babyface and looped back to the loopy inputs).

Now this whole thing is screwed up :-(. Suddenly high latency comes in although I have different settings and it crackles all the time. I hate using software which destroys my workflow with an update where I can’t go back to the working version.

I am so angry about that. Audioprocessing is such a sensible topic. So please include betatesters in your team for realtime-processing and different usages. This can’t be too difficult to sort these things out BEFORE release.

And yes, I posted this in the bugreport - form yesterday.

A short summary of the next post: MIDI-delay is somehow introduced when time passes. I just turn on microphon and a midi instrument (Cubasis alone, nothing else) and when I wait some time the MIDI (keyboard !! the internal onscreen keyboard remains tight) gets latency.

Now I tried with interapp audio and when I use microphone and keyboard suddenly big latence is inserted. When I go to audio and switch to higher latency and then back, everything goes back to normal. This is maximum not reliable! How can it be that Cubasis changes latency arbitrarily!?!?!

One hour later:
So O.K., there seem to be improvements with Interapp Connectivity. I’m digging deeper with this.
If I am able to connect cubasis via Audiobus3 with loopy reliably, I am happy again. But I’m in fear of these sudden changes with latency. That is a no go. I now worked for some minutes without problems.

IF Interapp connectivity really works now, that would be an improvement. I give it a chance and get back here, when I have it working stabele.

Some minutes later:
Again suddenly, out of nothing, there is latency on my midiinstrument, while using MIDI and Microphon in parallell. I go to settings, switch latency forth and back and the latency is gone.
Seems to be a stupid bug, but I can’t say, WHEN exactly this happens. The program should never change latency on it’s own.

Some hours later:
I left the setup running for a while, doing other things. When I hit the keyboard again, there was a horrible latency (felt like 0,5 seconds).
I now turned of all synchronisation from audiobus and will wait again. Curious, what will happen.

Short time later:
Without doing anything after a break playing again: latency! Now I will use only Audiobus for Output, not to send audio to loopy and see what happens

Again a short time later:
Again there occures latency after a while doing nothing. I bet it doesn’t matter if doing nothing or something.

Short time later:
It happens also without Audiobus!!! When I have Microphon with effects & Midi instrument on, after a while I get latency… This is the strangest thing ever…

Crazy shit:
This is MIDI-Latency drift!!! With the on screen keyboard it does not occure. It just happens with the Midi-keyboard connected. So now this is really reproducable and narrowed to the point. The Microphone is not delayed, internal inscreen keyboard is not delayed, only instruments played by externel Midi BECOME DELAYED over time!!

1 Like

Hi @mccy,

Thank you for your message.

Please provide us with a short clip that shows the problems and steps to get there, to allow our engineers to reproduce the problem.

Thanks
Lars

It would be a bit strange to record 30Minutes of video, to show thate midi instruments get delayed more and more after some time.

Ich würde das machen, 30min Video aufzuzeichnen, um zu zeigen, wie sich die Midi gesteuerten Instrumente mit der Zeit immer weiter verzögern, aber ich denke ich habe das Problem klar beschrieben…

LG

Martin Knott

Also auf deutsch ist es einfacher.
Ich minitore das Keyboardspiel über Midi Instrumente direkt. Am Anfang reagieren die Klänge perfekt auf den Punkt. Nach einiger Zeit, ohne irgendetwas anderes zu benutzen, zu starten whatever, erklingen die Sounds plötzlich BEIM SPIELEN verzögert. Ist mir noch nie begegnet sowas.

LG

Martin Knott

Hello
I get a similar issue after the update getting cracklings loose of synchro of midi real-time play because of the cracklings. I have tried to restart the iPad a few times but the issue stay an entire day an disappear the day after. Maybe this linked to a software running in background I can’t control.
Now everything work I don’t get cracklings anymore but it look the DSP never get silent on some projects even if I mute all tracks and the master.

And did you have that delayed midi when real-time playing even without the cracklings? I managed to get rid of the crackling, because I don’t use loopback in RME babyface anymore, because audiobus is very good working now.
With cubasis alone and a loaded software instrument played by midi it becomes more and more delayed after earlier than 1/2 an hour. It happens on ipad as well as iphone.

If I switch to another app I get the midi delayed my cubasis is open in background now and my midi play look delayed just after to open Safari. I have switched to cubasis and open settings to look the latency… and the delay has disappear and don’t come back even if I switch to the browser again. Don’t know if this linked to your issue don’t understand how the time can have an effect on the delay you get.
I try to made all in cubasis with Audio Units only like this everything is in and don’t need to switch apps.
Maybe you can do a vid of the start with everything playing and a vid of the end with the delay as Lars ask sure this can help to identify the issue.
Have a nice day :wave:t2::alien:

Thank you so much for your mental support!! Nice to be in discussion. I will make a video. Is there a screen capture video app for ios? I’m normally a windows guy :wink:

You are welcome :blush:
With iOS you have the screen recorder option in you need to enable it and put it on from the control center

Ah, I just notice, that a screen recorder makes no sense. I have to make a handy video, because one need to see the keyboard playing and hear the delayed sound. As I said, the problem is not with the onscreen keyboard. I try to do it this evening. Now I’m at least clear for myself, what I have to do :slight_smile:

1 Like

So these are two videos to show the problem…

between the first and second video there are just a few minutes time. Nothing has changed since the first video… but latency comes in :frowning:

https://youtu.be/6dpf4swRhA4

https://youtube.com/shorts/Yu8sUCY1dqk?feature=share

So I let the project rund, doing other things and actually theblatency is about 1 second!!! I don’t have to make video of that, have I?

I recorded that on video too:

https://youtu.be/oRfhKACUJ90

Clips provided in the posts above. Is it possible to share the project somehow?

I don’t know if the problem occures with other au plugins. At least it happens when I use QVox from Eventide!

It does not only occure with eventide Qvox. I have this problem also when using audiobus, so it is a cubasis problem. Anyway, the bug has been introduced to 3.3 so I hope for a quick fix to use this program again :frowning:

Hi @mccy,

Thank you for providing us with the additional information about your issue.

Is it possible to share the project somehow?

Please upload the project via Dropbox or similar, and share the link with us.

Please let us know how the MIDI connection is established between the CME device and the iPad/Cubasis. Do you use MIDI over Bluetooth?

Thanks,
Lars

I use USB midi, not bluetooth.

I didn’t manage to upload that project so far, but in the end we don’t need that anyway. I did many more tests and it is sufficiant (to make that growing latency over time thing happen) to either connect cubasis via audiobus OR to have Eventide Qvox in the project. I guess the problem will be with many more au plugins. Just try it with Qvox. It makes no difference b.t.w. where Qvox is placed. No matter if its on the midi track or another audiotrack.

Thank you for researching and identifying the issue with static and latency. I also have the same issues.

I am using an iPadPro 12.9. With a Duo Capture interface