Latency MIDI notes (but not audio)

Hello there,

I’ve just purchased Cubase 11 and found out that my midi notes were recorded before the beat… I know people having this issue and I tried to fix this but didn’t find a way to do so…

I changed le buffer size, use different VSTs, add “Asio compensation” and all but none of that got rid of the issue.

My setup : M-Audio Keystation 49MK3 + Focusrite 2i2 scarlett 3rd gen… That’s all ! I’ve only got this issue on cubase ! Does anyone know how to fix it it’s really annoying…?

Thanks in advance !!

Hi and welcome on the forum,

Please read thru this article.

There is a serious issue with midi timing. In cubase 10.5…
A disaster if you are writing music cues from a midi keyboard.
I’ve been using cubase for over 15 years, and midi in 10.5 is the worst I have ever experienced.
I keep searching these forums to see if someone has addressed this issue .
Maybe part of the disconnect is that if you are playing only live instruments, or pads, it’s not a problem. But once you are doing something that involves playing piano , fast string lines, drum parts from keyboard. Virtual instruments…you will feel the frustration.
Considering setting up old win 7/ win 10 computer,. And working on cubase 5 …which is sharp as a tack. When I strike a key…there it is. Fast runs…? No problem…and even better…when I play the midi back, it’s EXACTLY where I played it…instead of sounding and looking like a yard sale.

If anyone is experiencing this midi lag, midi early , midi garbage, please chime in with experience or answers.

Actually, I’m experiencing the same problem.
This is screenshot of live audio and MIDI recorded at the same time (playing 8th notes at 100bpm):


See that the latency varies.

Settings:


image

I’m using Cubase 10.5.30.
This is indeed a very serious issue.

Can you take your buffer size down further? From 256 to maybe 128?

Thanks.
Blain

This is with 128 samples:


image

I’ve tried with Presonus Studio One and it is even worse. It seems to be a problem with Windows.

Hi Martin,
I’m a bit confused by the article. How can we change our Windows configuration to try to improve the MIDI precision? If I buy a new laptop what should I look at to get the best MIDI precision? Are Macs affected by this?
Thanks!

When you lower your buffer , for use in studio one, are you getting crackling or pops, or does the audio still sound fine.?
This is why I am trying things out on a laptop, a 2nd computer and hopefully today on win 7.

But this does appear to be an improvement. Am I wrong? The notes seem less “off” at the 128 rate.

I am sure you have tried everything but I’m wondering if in cubase you can take the buffer down to 64 and enable ASIO protection on low. Also switch to 64 bit precision.

I can get the latency very low with an apollo 16 thunderbolt …but the sludgey slow real time midi response with notes placed early remains.

I. Am looking to try a non USB audio Interface with built in midi. To see if bypassing usb altogether solves this. (Connecting MOXf8 via midi cable rather than usb)

Unfortunately all my interfaces are without midi or midi capable but USB connected.

My old computer is win 7/ win 10 dual boot, and this is a computer on which I can set up an old focusrite saffire 26 io which is FireWire with built in midi. I’m quite sure I will not have these Midi problems once USB is eliminated from the equation.

Thank you all for all your answers ! Concerning the windows issue, I agree however I haven’t tried this option because it seems like all is fine now !! I’ve made few changes AND most importantly (I don’t know if that’s this button that does solve my issue but I tick the “Asio Compensation” ON the track itself !

I made a few screenshots for you to see my settings. Hopefully this will help someone !!! Keep me updated and thank you all for your answers !!

recford midi 2

1 Like