Latency on Cubase 9

deleted…

Disable Plugins with high plugin delay anywhere in your monitoring path and in addition to that, 512 samples is not really a low buffer setting

Thanks. But as written, I’ve tried all buffer settings, in a empty project, to no difference at all. Same latency.

Control room active…any plugins in there?? (new empty project does not clear the control room)

Thanks, I’ve checked, there’s none.

These are abnormal high values for a MR816CSX. Even on 512 samples it should be much lower and more in the range of 20-30 ms or so. Are you sure you’re using the dedicated ASIO driver? Because it sounds you might have the Steinberg Low Latency or WDM driver selected?

If you are on Windows, use the YSFWUtility and set the IEEE1394 buffer size to “Medium”:
https://helpcenter.steinberg.de/hc/en-us/articles/206760690-MR816-Resolving-audio-performance-issues

I had the same problem and I also tried everything you have described. This adjustment finally did the trick for me.

Best regards

Miloslav

Thank for the replies.

@valsolim, I tried changing those settings. Seems to be helping abit. But I’m more down to 40-50msec now.

Isn’t there a way to make it go 0msec? I really don’t understand why it’s so hard, when in Fruity Loops, I can max up the buffer size, and playback would still be on 0. It’s wierd, and frustrating AF.

Wow so Fruity Loops has a build in time machine, I didn’t know that.

Direct Monitoring?

As shown in pic 2, it’s enabled.