Latency on new computer way too high for Cubase13 Pro to be usable - Help!

Can you share what that problem was as it seems to be an overlooked missing clue here at the bottom of the chain for the start of things?

Hippo

From the LatencyMon screenshot, it looks like a whole lot of processes are problematic. Even the LatencyMon process itself - highest execution time 2.64 ms, on my system 0.099 ms.
(i9 12900K, AMD 6700XT, 64 gb RAM). Hopefully, the new machine will be fit for purpose.
For reference (only 3 mins, but I opened C13 with a fairly large project in that time):

@hippo - the computer stopped working in the small hours of the morning and went to the “Recover” screen. Not every day but almost every other day. Since the OS wipe and fresh install this has not yet happened - but that was only three days ago.

Update:

Thanks for all your suggestions - Unfortunately, they have not had much positive effect on my system… However I have found a solution that works on my system :

nVidia told me that they are aware of latency problems with their recent drivers and are “addressing” them. The new nVidia Studio Driver (551.86) helped a bit (but not all that much). I have tried some other suggested settings in the BIOS, Windows setting and nVidia Control Panel without much impact - although it is difficult to tell as LatencyMon gives quite different results each time it is run. However the nVidia driver has always showed 5-10 times worse results than anything else.

I recently found this very recent reddit page which is very helpful. Reddit - Dive into anything
See the “DPC Latency spike potential workaround(s)” near the bottom of the post.

The third suggestion had an enormous impact ! LatencyMon now mostly thinks that my system is suitable for real-time audio. The nVidia driver is no longer the worst offender. I can even run Cubase 13 playback with no dropouts, clicks or stutters with a buffer size of just 32 for the Focusrite Scarlett 2i2 Gen 4 !

  • Disable Hardware Accelerated GPU Scheduling (HAGS) in Windows settings. May help with DPC Latency on some systems but impacts Series 40 (Lovelace) DLLS3 Frame Generation feature and AMD’s FSR3 Frame Generation feature

After running for 26 min - I get this from LatencyMon :

The above solution may or may not work for you …
Now to state the obvious from my 3 week journey down the rabbit hole :-

I have noticed that audio latency problems have been around for a LONG time - and that most “solutions” from Google searches are horribly out of date, or very specific and might work only for the person’s system, or just plain hogwash ! Many of them are exceedingly technical and not really understandable by lesser mortals!

I have also noticed that where people have gone so far as to show screenshots of changing specific Windows 11 settings or nVidia settings that they are also out of date and do not resemble the screens you see today on a fully updated system. This indicates (of course) that Microsost/nVidiA etc are "fixing stuff continuously - we hope.

So, beware !! When searching for solutions try to restrict the results to the last few months in any search if you can!

Thanks again for all who tried to help !
Regards
Andy

2 Likes

Awesome! Good job finding that. I am curious where is that setting because I’ve never heard of it and can’t find it here.
(nevermind, I just found it).

edit:
BTW, I have that setting, it is enabled but I don’t have any issue with my DAW or latency here.

But only if your system supports it - I have an AMD 6700 XT with up to date drivers, an i9 12900 and an up to date Windows 10, but the HAGS option doesn’t appear in my settings, even with a search.

Thanks so much @Hooby2

Maybe this link will help ?
How to Enable Hardware-Accelerated GPU Scheduling in Windows 10 and 11 (howtogeek.com)

I think you misunderstood. This setting is only available if your graphics card supports it.

My anti-tracking setting won’t allow me to view how-to-geek, but I assume it directs me to Windows Settings\Display\Graphics Settings. This is how it looks on my system:

1 Like

Here you go:

If you look carefully at the screenshot I provided, you’ll see that I did indeed go to Settings>System>Display>Graphics Settings, which is the window in the screenshot, and you’ll see that there is no such option.

Hmmm, I am also on Windows 10, and I can’t see this function, V 22H2, Built 19045.4170…any ideas why I can’t see the function?

Cheers!

Because your graphics card does not support this function.

I see, cheers!

I said this two days ago!