Latency on record and output

Hi All;

Please forgive any shortcomings in my post here as I am a rookie on this MIDI stuff (and DAW recording in general but I am a programmer of 20 years, so I can pick up pretty quickly).

A similar issue was posted in the “Solved Issues” forum, but I am not able to post a follow up there and the solutions detailed there have not solved my issue. I also have not found any solution in the other posts I have read regarding “latency”. Maybe it is there, but if so, I did not find.

When I try to monitor my keyboard (controller and system specs at end) input using ANY VST instrument, I get a long delay on hearing the sound I have played (probably 250 miliseconds or so). There is also the same delay in the recording of those key hits on the MIDI timeline. This does NOT happen with a new file, but the files I am trying to work with are not complex (10-15 tracks with about 70% of them being audio tracks). I have tried taking a project that had 8 tracks and removed EVERYTHING except my new MIDI track and turned off all inserts/eq. Latency is still there. I have also tried to “freeze” all tracks except the one I am trying to record, but no luck. But a new track, no problem. It may be worth noting that on the transport control, the MIDI In Activity meter responds in real time, but the Audio Activity output meter there and on the track in question show delay. This tells me that the keyboard is sending and Cubase is receiving the command in real time (or un-noticeable latency like the 3.900 Milliseconds that my feedback tells me the system is providing with current settings), but something in Cubase is preventing it from being recorded and sent back for monitoring in real time.

I have included multiple print screens here to display my current settings.
Project_With_VST_Oct05_2012.jpg
MIDI_Port_Settings.jpg
Mackie_OnyxBlackjack_ASIO_Settings.jpg
I have tried dozens of changes, but certainly did not try every combination of all settings, and I am sure there are some settings that I don’t know about that may or may not be causing this problem. Any help is very much appreciated.

System specs are as follows:

I have a M-Audio Prokeys 88 MIDI controller. I have it connected via a USB 2 port. My sound/recording device is a Mackie Onyx Blackjack 2x2 USB Sound Recording Interface. It too is connected through a USB 2 port and I am using the Mackie ASIO Driver. The only other USB devices connected to this machine are keyboard, mouse and the dongle for Cubase licensing.

PC/Desktop
OS Windows 7 Pro 64 bit
Cubase Pro 8.0.30
CPU i7-5820k
Motherboard ASUS X99 Sabertooth
Memory Crucial DDR4 2133Mhz x 24 GB
NVIDIA GeForce GTX 750 Ti
Hard Drives M.2 SM951 256 GB (System Drive)
Samsung EVO850 1TB (Music Production Drive)
Corsair Force GT 128 GB
WD Red 4tb
WD Red 4tb in RAID5 Array

Thanks to all who spend any time on this.

Cheers~
Bill Blair

Nevermind. I got it. Turns out the “Constrain Delay Compensation” button was in the wrong state (should be orange when recording to get rid of the delay in my case anyway). Hope this helps someone who is trying to figure out a similar issue.

Cheers~
Bill Blair

Yeap. Plugin Delay can not be prevented even at low buffer settings as most plugins have a fixed internal buffer that can not be changed. I also recommend to set Asio Guard to low settings. I have a bit more delay at high settings.

Thanks for that tip Novikthewise. I will experiment with the ASIO Guard settings.

Cheers~
Bill Blair